From 4f857db335de6935077d4866c51dd9d6851fed1d Mon Sep 17 00:00:00 2001
From: "nslu2-linux.adm@bkbits.net" <nslu2-linux.adm@bkbits.net>
Date: Tue, 22 Feb 2005 12:53:55 +0000
Subject: Merge bk://oe-devel.bkbits.net/openembedded into
 bkbits.net:/repos/n/nslu2-linux/openembedded

2005/02/21 17:35:27-06:00 ti.com!kergoth
Kill the ipkg paths patch, since its busted.

2005/02/21 17:33:13-06:00 ti.com!kergoth
Fix sbindir in native.bbclass and cross.bbclass.  Thanks to Jordan Crouse for reporting.

2005/02/21 17:13:19-06:00 ti.com!kergoth
Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit.

2005/02/21 17:09:46-06:00 ti.com!kergoth
Merge oe-devel@oe-devel.bkbits.net:openembedded
into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded

2005/02/21 17:09:03-06:00 ti.com!kergoth
Run a sed script against our packages to fix some hardcoded target path
references.  As always when I do things like this, if packages you maintain
were touched by this, please do a sanity check to ensure the sed script didn't
run wild.

2005/02/21 15:49:47-06:00 ti.com!kergoth
Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO.

BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
---
 packages/linux-uml/linux-uml_2.6.11-rc2-mm1.bb | 58 ++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)

(limited to 'packages/linux-uml')

diff --git a/packages/linux-uml/linux-uml_2.6.11-rc2-mm1.bb b/packages/linux-uml/linux-uml_2.6.11-rc2-mm1.bb
index e69de29bb2..bdbbd85fb8 100644
--- a/packages/linux-uml/linux-uml_2.6.11-rc2-mm1.bb
+++ b/packages/linux-uml/linux-uml_2.6.11-rc2-mm1.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "User Mode Linux Kernel"
+SECTION = "kernel"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
+RCV = "${@bb.data.getVar('PV',d,True).split('-')[1]}"
+MMV = "${@bb.data.getVar('PV',d,True).split('-')[2]}"
+LV = "2.6.10"
+PR = "r2"
+
+SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-${LV}.tar.bz2 \
+           http://www.kernel.org/pub/linux/kernel/v2.6/testing/patch-${KV}-${RCV}.bz2;patch=1 \
+           http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/${KV}-${RCV}/${KV}-${RCV}-${MMV}/${KV}-${RCV}-${MMV}.gz;patch=1 \
+           file://defconfig"
+#http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-core-on-panic;patch=1 \
+#http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-pretend-to-be-i586;patch=1 \
+#http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-general-protection-fault;patch=1 \
+#http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-x11-fb;patch=1 \
+
+S = "${WORKDIR}/linux-${LV}"
+
+inherit kernel
+
+COMPATIBLE_HOST = 'i.86.*-linux'
+
+export OS = "Linux"
+ARCH = "um"
+SUBARCH = "${TARGET_ARCH}"
+KERNEL_IMAGETYPE = "linux"
+EXTRA_OEMAKE = "'CC=${KERNEL_CC}' 'LD=${KERNEL_LD}' \
+		'SUBARCH=${SUBARCH}'"
+EXTRA_CFLAGS += "-I${includedir}"
+
+do_configure() {
+	install -m 0644 ${WORKDIR}/defconfig .config
+	oe_runmake oldconfig
+}
+
+do_compile() {
+	unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+        install -d arch/um/include/linux/
+        install -m 0644 include/linux/inet.h arch/um/include/linux/
+	kernel_do_compile
+}
+
+do_stage_prepend() {
+	install -d arch/um/boot/
+	ln -sf ${S}/linux arch/um/boot/linux
+}
+
+do_install() {
+        unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+        #oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" modules_install
+        install -d ${D}/boot
+        install -m 0755 linux ${D}/boot/linux-${PV}
+        install -m 0644 System.map ${D}/boot/System.map-${PV}
+        install -m 0644 .config ${D}/boot/config-${PV}
+}
-- 
cgit v1.2.3