From 52b0b44449952398e59147730e3fae6c8d2f0508 Mon Sep 17 00:00:00 2001
From: David Karlstrom <daka@thg.se>
Date: Sat, 30 Jul 2005 20:34:12 +0000
Subject: Update to follow the FHS and use update-alternatives for gzip, gunzip
 and zcat

---
 packages/gzip/gzip_1.3.5.bb | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

(limited to 'packages/gzip')

diff --git a/packages/gzip/gzip_1.3.5.bb b/packages/gzip/gzip_1.3.5.bb
index e99c76dcb4..a138221367 100644
--- a/packages/gzip/gzip_1.3.5.bb
+++ b/packages/gzip/gzip_1.3.5.bb
@@ -5,6 +5,7 @@ MAINTAINER = "Greg Gilbert <greg@treke.net>"
 DESCRIPTION = "gzip (GNU zip) is a compression utility designed \
 to be a replacement for 'compress'. The GNU Project uses it as \
 the standard compression program for its system."
+PR = "r1"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/g/gzip/gzip_${PV}.orig.tar.gz \
 	   file://configure.patch;patch=1"
@@ -12,3 +13,25 @@ SRC_URI = "${DEBIAN_MIRROR}/main/g/gzip/gzip_${PV}.orig.tar.gz \
 S = "${WORKDIR}/gzip-${PV}"
 
 inherit autotools
+
+do_install () {
+	autotools_do_install
+	# Rename and move files into /bin (FHS)
+	install -d ${D}${base_bindir}
+	mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip.${PN}
+	mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip.${PN}
+	mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat.${PN}
+}
+
+pkg_postinst_${PN} () {
+	update-alternatives --install ${base_bindir}/gunzip gunzip gunzip.${PN} 100
+	update-alternatives --install ${base_bindir}/gzip gzip gzip.${PN} 100
+	update-alternatives --install ${base_bindir}/zcat zcat zcat.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+	update-alternatives --remove gunzip gunzip.${PN}
+	update-alternatives --remove gzip gzip.${PN}
+	update-alternatives --remove zcat zcat.${PN}
+}
+
-- 
cgit v1.2.3