From f32a5e8a24f396acba37e9dfd01a9062cbdabd66 Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@openembedded.org>
Date: Mon, 2 Mar 2009 15:36:02 +0100
Subject: gstreamer: package libs seperately to account for things moving
 between -good, -bad, -ugly and -base.

---
 packages/gstreamer/gst-plugins-bad_0.10.6.bb   | 2 +-
 packages/gstreamer/gst-plugins-base_0.10.22.bb | 2 ++
 packages/gstreamer/gst-plugins-good_0.10.13.bb | 2 ++
 packages/gstreamer/gst-plugins-ugly_0.10.10.bb | 2 ++
 packages/gstreamer/gst-plugins.inc             | 7 +++++++
 5 files changed, 14 insertions(+), 1 deletion(-)

(limited to 'packages/gstreamer')

diff --git a/packages/gstreamer/gst-plugins-bad_0.10.6.bb b/packages/gstreamer/gst-plugins-bad_0.10.6.bb
index a8d87833ac..df7bf75852 100644
--- a/packages/gstreamer/gst-plugins-bad_0.10.6.bb
+++ b/packages/gstreamer/gst-plugins-bad_0.10.6.bb
@@ -1,5 +1,5 @@
 require gst-plugins.inc
-PR = "r1"
+PR = "r2"
 
 SRC_URI += "file://vorbisenc.h file://vorbisdec.h \
             file://gst-plugins-directfb-fix.patch;patch=1;pnum=2 \
diff --git a/packages/gstreamer/gst-plugins-base_0.10.22.bb b/packages/gstreamer/gst-plugins-base_0.10.22.bb
index 4d6f71e3d0..92f2f56fa3 100644
--- a/packages/gstreamer/gst-plugins-base_0.10.22.bb
+++ b/packages/gstreamer/gst-plugins-base_0.10.22.bb
@@ -2,6 +2,8 @@ require gst-plugins.inc
 
 PROVIDES += "gst-plugins"
 
+PR = "r1"
+
 # gst-plugins-base only builds the alsa plugin
 # if alsa has been built and is present.  You will
 # not get an error if this is not present, just 
diff --git a/packages/gstreamer/gst-plugins-good_0.10.13.bb b/packages/gstreamer/gst-plugins-good_0.10.13.bb
index d9f0349101..b77d1fcf47 100644
--- a/packages/gstreamer/gst-plugins-good_0.10.13.bb
+++ b/packages/gstreamer/gst-plugins-good_0.10.13.bb
@@ -1,5 +1,7 @@
 require gst-plugins.inc
 
+PR = "r1"
+
 inherit gconf 
 
 EXTRA_OECONF += " --enable-experimental  --enable-gst_v4l2 --enable-gconftool  --enable-external --with-check=no"
diff --git a/packages/gstreamer/gst-plugins-ugly_0.10.10.bb b/packages/gstreamer/gst-plugins-ugly_0.10.10.bb
index 062404179e..0678e229f8 100644
--- a/packages/gstreamer/gst-plugins-ugly_0.10.10.bb
+++ b/packages/gstreamer/gst-plugins-ugly_0.10.10.bb
@@ -1,5 +1,7 @@
 require gst-plugins.inc
 
+PR = "r1"
+
 DEPENDS += "gst-plugins-base mpeg2dec libsidplay"
 
 SRC_URI += "\
diff --git a/packages/gstreamer/gst-plugins.inc b/packages/gstreamer/gst-plugins.inc
index c0b15ef38b..3bf29ad3e9 100644
--- a/packages/gstreamer/gst-plugins.inc
+++ b/packages/gstreamer/gst-plugins.inc
@@ -19,7 +19,9 @@ LIBV = "0.10"
 python populate_packages_prepend () {
 	gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
 	postinst = bb.data.getVar('plugin_postinst', d, 1)
+	glibdir = bb.data.expand('${libdir}', d)
 
+	do_split_packages(d, glibdir, '^lib(.*)\.so\.*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True)
 	do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst, extra_depends='')
 	do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)', extra_depends='')
 	
@@ -42,5 +44,10 @@ python populate_packages_prepend () {
 
 ALLOW_EMPTY = "1"
 
+PACKAGES += "${PN}-apps"
+FILES_${PN}-apps = "${bindir}"
+
+FILES_${PN} = ""
 FILES_${PN}-dbg += "${libdir}/gstreamer-${LIBV}/.debug"
 
+
-- 
cgit v1.2.3