From 12e67884da766a69ee3b46f908da105a1c92187a Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@openembedded.org>
Date: Tue, 8 May 2007 17:17:40 +0000
Subject: pidgin: add first stab at a 2.0.0 recipes Known defects: ls
 image/usr/lib/purple-2/ libjabber.so  libjabber.so.0  libjabber.so.0.0.0 
 liboscar.so  liboscar.so.0  liboscar.so.0.0.0  log_reader.so The jabber and
 oscor protocol don't get packaged because do_split_packages doesn't do
 symlinks. Since I don't know whether pidgin scans for *.so or lib* on startup
 I haven't packaged these. Improvements welcome

---
 packages/gaim/pidgin.inc                         | 74 ++++++++++++++++++++++++
 packages/gaim/pidgin/.mtn2git_empty              |  0
 packages/gaim/pidgin/gconf-no-errors.patch       | 12 ++++
 packages/gaim/pidgin/sanitize-configure.ac.patch | 33 +++++++++++
 packages/gaim/pidgin_2.0.0.bb                    |  8 +++
 5 files changed, 127 insertions(+)
 create mode 100644 packages/gaim/pidgin.inc
 create mode 100644 packages/gaim/pidgin/.mtn2git_empty
 create mode 100644 packages/gaim/pidgin/gconf-no-errors.patch
 create mode 100644 packages/gaim/pidgin/sanitize-configure.ac.patch
 create mode 100644 packages/gaim/pidgin_2.0.0.bb

(limited to 'packages/gaim')

diff --git a/packages/gaim/pidgin.inc b/packages/gaim/pidgin.inc
new file mode 100644
index 0000000000..797be7a6f2
--- /dev/null
+++ b/packages/gaim/pidgin.inc
@@ -0,0 +1,74 @@
+SECTION = "x11/network"
+DESCRIPTION = "multi-protocol instant messaging client"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ ncurses gnutls virtual/libintl gstreamer dbus"
+RRECOMMENDS_${PN} = "pidgin-protocol-irc pidgin-protocol-jabber pidgin-plugin-docklet"
+
+EXTRA_OECONF = " \
+                --disable-audio \
+		--disable-perl \
+		--disable-tcl \
+		--disable-deprecated \
+		--disable-gevolution \
+		--x-includes=${STAGING_INCDIR} \
+		--x-libraries=${STAGING_LIBDIR} \
+		--enable-gnutls=yes \
+		--with-ncurses-headers=${STAGING_INCDIR} \
+		--with-gnutls-includes=${STAGING_INCDIR} \
+		--with-gnutls-libs=${STAGING_LIBDIR} \
+		"
+
+PACKAGES =+ "libpurple libpurple-dev libpurple-dbg finch finch-dev finch-dbg"
+
+
+LEAD_SONAME = "libpurple.so.0"
+FILES_libpurple     = "${libdir}/libpurple*.so.*"
+FILES_libpurple-dev = "${libdir}/libpurple* \
+                       ${libdir}/purple-2/*.la " 
+FILES_libpurple-dbg = "${libdir}/.debug/libpurple* \
+                       ${libdir}/purple-2/.debug"
+FILES_finch         = "${bindir}/finch" 
+FILES_finch-dev     = "${libdir}/finch/*.la" 
+FILES_finch-dbg     = "${bindir}/.debug/finch \
+                       ${libdir}/finch/.debug"
+
+FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
+	    ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+	    /bin /sbin /lib/*.so* ${datadir}/${PN} ${libdir}/${PN}/*.so \
+	    ${datadir}/pixmaps ${datadir}/applications \
+	    ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+	    ${libdir}/bonobo/servers ${datadir}/icons"
+FILES_${PN}-dev += "${libdir}/pidgin/*.la"
+
+inherit autotools gettext pkgconfig gconf
+
+PACKAGES_DYNAMIC = "libpurple-protocol-* libpurple-plugin-* pidgin-plugin-* finch-plugin-*"
+
+python populate_packages_prepend () {
+	root   = bb.data.expand('${libdir}/pidgin', d)
+        purple = bb.data.expand('${libdir}/purple-2', d)
+        finch  = bb.data.expand('${libdir}/finch', d)
+
+	do_split_packages(d, root, '^([^l][^i][^b].*)\.so$',
+			   output_pattern='pidgin-plugin-%s',
+			   description='Pidgin plugin %s',
+			   prepend=True)
+
+        do_split_packages(d, purple, '^lib(.*)\.so$',
+			   output_pattern='libpurple-protocol-%s',
+			   description='Libpurple protocol plugin for %s',
+			   prepend=True)
+
+        do_split_packages(d, purple, '^([^l][^i][^b].*)\.so$',
+                           output_pattern='libpurple-plugin-%s',
+                           description='libpurple plugin %s',
+                           prepend=True)
+
+        do_split_packages(d, finch, '^([^l][^i][^b].*)\.so$', 
+                           output_pattern='finch-plugin-%s',
+                           description='Finch plugin %s',
+                           prepend=True)
+
+
+}
diff --git a/packages/gaim/pidgin/.mtn2git_empty b/packages/gaim/pidgin/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
diff --git a/packages/gaim/pidgin/gconf-no-errors.patch b/packages/gaim/pidgin/gconf-no-errors.patch
new file mode 100644
index 0000000000..9a95175ac9
--- /dev/null
+++ b/packages/gaim/pidgin/gconf-no-errors.patch
@@ -0,0 +1,12 @@
+--- /tmp/Makefile.am	2007-05-08 18:39:49.000000000 +0200
++++ pidgin-2.0.0/libpurple/gconf/Makefile.am	2007-05-08 18:40:13.755251000 +0200
+@@ -8,8 +8,7 @@
+ 
+ if GCONF_SCHEMAS_INSTALL
+ install-data-local:
+-	GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1 | \
+-		grep -v "^WARNING: failed to install schema" | grep -v "^Attached schema" 1>&2
++	GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1 
+ else
+ install-data-local:
+ endif
diff --git a/packages/gaim/pidgin/sanitize-configure.ac.patch b/packages/gaim/pidgin/sanitize-configure.ac.patch
new file mode 100644
index 0000000000..a77d64f40b
--- /dev/null
+++ b/packages/gaim/pidgin/sanitize-configure.ac.patch
@@ -0,0 +1,33 @@
+--- /tmp/configure.ac	2007-05-08 17:29:02.000000000 +0200
++++ pidgin-2.0.0/configure.ac	2007-05-08 17:30:30.325251000 +0200
+@@ -472,7 +472,7 @@
+ 	if test "x$enable_consoleui" = "xyes"; then
+ 		dnl # Some distros put the headers in ncursesw/, some don't
+ 		found_ncurses_h=no
+-		for location in $ac_ncurses_includes $NCURSES_HEADERS /usr/include/ncursesw /usr/include
++		for location in $ac_ncurses_includes $NCURSES_HEADERS 
+ 		do
+ 			f="$location/ncurses.h"
+ 			AC_CHECK_HEADER($f,[
+@@ -1860,10 +1860,6 @@
+ 			KRB4_CFLAGS="$KRB4_CFLAGS -I${kerberos}/include/kerberosIV"
+ 		fi
+ 		KRB4_LDFLAGS="-L${kerberos}/lib"
+-	elif test -d /usr/local/include/kerberosIV ; then
+-		KRB4_CFLAGS="-I/usr/local/include/kerberosIV"
+-	elif test -d /usr/include/kerberosIV ; then
+-		KRB4_CFLAGS="-I/usr/include/kerberosIV"
+ 	fi
+ 	AC_DEFINE(ZEPHYR_USES_KERBEROS, 1, [Define if kerberos should be used in Zephyr.])
+ 
+@@ -1896,10 +1892,6 @@
+ 		ZEPHYR_LDFLAGS="-L${zephyr}/lib"
+ 	elif test -d /usr/athena/include/zephyr ; then
+ 		ZEPHYR_CFLAGS="-I/usr/athena/include"
+-	elif test -d /usr/include/zephyr ; then
+-		ZEPHYR_CFLAGS="-I/usr/include"
+-	elif test -d /usr/local/include/zephyr ; then
+-		ZEPHYR_CFLAGS="-I/usr/local/include"
+ 	fi
+ 	AC_DEFINE(LIBZEPHYR_EXT, 1 , [Define if external libzephyr should be used.])
+ 	AM_CONDITIONAL(EXTERNAL_LIBZEPHYR, test "x$zephyr" != "xno")
diff --git a/packages/gaim/pidgin_2.0.0.bb b/packages/gaim/pidgin_2.0.0.bb
new file mode 100644
index 0000000000..a39e7aeaf9
--- /dev/null
+++ b/packages/gaim/pidgin_2.0.0.bb
@@ -0,0 +1,8 @@
+require pidgin.inc
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
+           file://sanitize-configure.ac.patch;patch=1 \
+           file://gconf-no-errors.patch;patch=1 \
+	  " 
+
+
-- 
cgit v1.2.3