From b87cac1cf23eab6ad1e8a7498702f408263c2ae4 Mon Sep 17 00:00:00 2001
From: Michael Lauer <mickey@vanille-media.de>
Date: Sat, 13 Aug 2005 14:44:45 +0000
Subject: E17 files - remove unnecessary explicit binconfig settings - use
 ${sysconfdir} and ${sbindir} instead of hardcoding paths

---
 packages/e17/e-iconbar_20050810.bb |  2 +-
 packages/e17/engage_20050810.bb    | 13 ++++---------
 packages/e17/entice_20050810.bb    |  4 ++--
 packages/e17/examine_20050810.bb   | 12 +++---------
 4 files changed, 10 insertions(+), 21 deletions(-)

(limited to 'packages/e17')

diff --git a/packages/e17/e-iconbar_20050810.bb b/packages/e17/e-iconbar_20050810.bb
index 0d3c14cc06..9eae8a37b2 100644
--- a/packages/e17/e-iconbar_20050810.bb
+++ b/packages/e17/e-iconbar_20050810.bb
@@ -13,4 +13,4 @@ inherit autotools
 
 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
 
-FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} /etc/* /usr/sbin/*"
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir} ${sbindir}"
diff --git a/packages/e17/engage_20050810.bb b/packages/e17/engage_20050810.bb
index b74d21f028..e8f9467239 100644
--- a/packages/e17/engage_20050810.bb
+++ b/packages/e17/engage_20050810.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "engage, e17 icon dock"
+DESCRIPTION = "Engage is the E17 icon dock"
 DEPENDS = "esmart virtual/imlib2 edje virtual/ecore virtual/evas ewl e-wm"
 LICENSE = "MIT"
 SECTION = "e"
@@ -8,6 +8,8 @@ PR = "r0"
 SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=misc/engage"
 S = "${WORKDIR}/engage"
 
+inherit autotools pkgconfig binconfig
+
 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
 
 do_prepsources () {
@@ -15,12 +17,5 @@ do_prepsources () {
 }
 addtask prepsources after do_fetch before do_unpack
 
-export EET_CONFIG = "${STAGING_BINDIR}/eet-config"
-export EVAS_CONFIG = "${STAGING_BINDIR}/evas-config"
-export ECORE_CONFIG = "${STAGING_BINDIR}/ecore-config"
-export EMBRYO_CONFIG = "${STAGING_BINDIR}/embryo-config"
-export EDJE_CONFIG = "${STAGING_BINDIR}/edje-config"
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir} ${sbindir}"
 
-FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} /etc/* /usr/sbin/*"
-
-inherit autotools pkgconfig binconfig
diff --git a/packages/e17/entice_20050810.bb b/packages/e17/entice_20050810.bb
index ac454e7189..667d3f4da8 100644
--- a/packages/e17/entice_20050810.bb
+++ b/packages/e17/entice_20050810.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "Entice is a picture viewer"
+DESCRIPTION = "Entice is the E17 picture viewer"
 SECTION = "e/apps"
 # can also depend on GIMP for editing
 DEPENDS = "virtual/evas edb virtual/ecore edje"
@@ -15,5 +15,5 @@ inherit autotools
 
 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
 
-FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} /etc/* /usr/sbin/*"
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir} ${sbindir}"
 
diff --git a/packages/e17/examine_20050810.bb b/packages/e17/examine_20050810.bb
index 07ed88c0f5..6e79fd946f 100644
--- a/packages/e17/examine_20050810.bb
+++ b/packages/e17/examine_20050810.bb
@@ -11,17 +11,11 @@ S = "${WORKDIR}/examine"
 
 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
 
+inherit autotools pkgconfig binconfig
+
 do_prepsources () {
   make clean distclean || true
 }
 addtask prepsources after do_fetch before do_unpack
 
-export EET_CONFIG = "${STAGING_BINDIR}/eet-config"
-export EVAS_CONFIG = "${STAGING_BINDIR}/evas-config"
-export ECORE_CONFIG = "${STAGING_BINDIR}/ecore-config"
-export EMBRYO_CONFIG = "${STAGING_BINDIR}/embryo-config"
-export EDJE_CONFIG = "${STAGING_BINDIR}/edje-config"
-
-FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} /etc/* /usr/sbin/*"
-
-inherit autotools pkgconfig binconfig
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir} ${sbindir}"
-- 
cgit v1.2.3