From 344ce87c05155c4fff8b2091b78552b8213b951d Mon Sep 17 00:00:00 2001
From: Justin Patrin <papercrane@gmail.com>
Date: Sat, 13 Aug 2005 10:23:11 +0000
Subject: Add patches and configuration to make entrance(d) actually work

---
 packages/e17/entrance/Xserver.patch                | 22 +++++++++
 packages/e17/entrance/allow-missing-xsession.patch | 19 ++++++++
 packages/e17/entrance/config-db.patch              | 56 ++++++++++++++++++++++
 packages/e17/entrance_20050810.bb                  | 11 ++++-
 4 files changed, 106 insertions(+), 2 deletions(-)
 create mode 100644 packages/e17/entrance/Xserver.patch
 create mode 100644 packages/e17/entrance/allow-missing-xsession.patch
 create mode 100644 packages/e17/entrance/config-db.patch

(limited to 'packages/e17')

diff --git a/packages/e17/entrance/Xserver.patch b/packages/e17/entrance/Xserver.patch
new file mode 100644
index 0000000000..296a7bccf4
--- /dev/null
+++ b/packages/e17/entrance/Xserver.patch
@@ -0,0 +1,22 @@
+--- entrance/src/daemon/Entranced.h.~1.7.~	2004-05-19 21:02:09.000000000 -0700
++++ entrance/src/daemon/Entranced.h	2005-08-13 02:00:02.000000000 -0700
+@@ -18,7 +18,7 @@
+ 
+ #define ENTRANCED_DEBUG 1
+ 
+-#define X_SERVER "/usr/X11R6/bin/X -quiet"
++#define X_SERVER "/etc/X11/Xserver"
+ //#define X_SERVER "/usr/X11R6/bin/Xnest -full"
+ #define X_DISP ":0"             /* only used if DISPLAY variable is NOT set */
+ #define ENTRANCE PREFIX "/bin/entrance_wrapper"
+--- entrance/src/daemon/spawner.c.~1.25.~	2005-05-28 02:31:14.000000000 -0700
++++ entrance/src/daemon/spawner.c	2005-08-13 02:20:13.000000000 -0700
+@@ -155,7 +155,7 @@
+         sigaction(SIGUSR1, &_entrance_x_sa, NULL);
+       /* FIXME: need to parse command and NOT go thru /bin/sh!!!! */
+       /* why? some /bin/sh's wont pass on this SIGUSR1 thing... */
+-        execl("/bin/sh", "/bin/sh", "-c", x_cmd, NULL);
++        execl("/bin/bash", "/bin/bash", "-c", x_cmd, NULL);
+         syslog(LOG_WARNING, "Could not execute X server.");
+         exit(1);
+      default:
diff --git a/packages/e17/entrance/allow-missing-xsession.patch b/packages/e17/entrance/allow-missing-xsession.patch
new file mode 100644
index 0000000000..c475e46fe2
--- /dev/null
+++ b/packages/e17/entrance/allow-missing-xsession.patch
@@ -0,0 +1,19 @@
+--- entrance/configure.in.~1.42.~	2005-07-29 23:15:58.000000000 -0700
++++ entrance/configure.in	2005-08-13 03:11:41.000000000 -0700
+@@ -190,11 +190,11 @@
+ 	    fi
+ 	]
+ )
+-if test ! -x $xsession ; then
+-    AC_MSG_WARN([** no $xsession file on this system **])
+-    AC_MSG_WARN([** Perhaps you need to specify --with-xsession **])
+-    xsession="You should reconfigure --with-xsession"
+-fi
++#if test ! -x $xsession ; then
++#    AC_MSG_WARN([** no $xsession file on this system **])
++#    AC_MSG_WARN([** Perhaps you need to specify --with-xsession **])
++#    xsession="You should reconfigure --with-xsession"
++#fi
+ 
+ AC_DEFINE_UNQUOTED(ENTRANCE_XSESSION, "$xsession", [Xsession script])
+ AC_SUBST(xsession)
diff --git a/packages/e17/entrance/config-db.patch b/packages/e17/entrance/config-db.patch
new file mode 100644
index 0000000000..5e965057ba
--- /dev/null
+++ b/packages/e17/entrance/config-db.patch
@@ -0,0 +1,56 @@
+--- entrance/data/config/build_config.sh.in~	2005-08-13 02:56:11.000000000 -0700
++++ entrance/data/config/build_config.sh.in	2005-08-13 02:56:35.000000000 -0700
+@@ -3,7 +3,7 @@
+ rm -f $DB
+ 
+ # set auth to 1 for pam, 2 for shadow
+-edb_ed $DB add /entrance/auth int @auth_mode@
++edb_ed $DB add /entrance/auth int 0
+ 
+ # uncomment the below to enable experimental OpenGL hardware acceleration
+ #edb_ed $DB add /entrance/engine int 1
+@@ -25,25 +25,25 @@
+ edb_ed $DB add /entrance/session/0/icon str "default.png"
+ edb_ed $DB add /entrance/session/1/icon str "enlightenment.png"
+ edb_ed $DB add /entrance/session/1/title str "Enlightenment"
+-edb_ed $DB add /entrance/session/1/session str "Enlightenment"
+-edb_ed $DB add /entrance/session/2/session str "kde"
+-edb_ed $DB add /entrance/session/2/title str "KDE"
+-edb_ed $DB add /entrance/session/2/icon str "kde.png"
+-edb_ed $DB add /entrance/session/3/session str "gnome"
+-edb_ed $DB add /entrance/session/3/title str "Gnome"
+-edb_ed $DB add /entrance/session/3/icon str "gnome.png"
+-edb_ed $DB add /entrance/session/4/session str "blackbox"
+-edb_ed $DB add /entrance/session/4/title str "Blackbox"
+-edb_ed $DB add /entrance/session/4/icon str "blackbox.png"
+-edb_ed $DB add /entrance/session/5/session str "sawfish"
+-edb_ed $DB add /entrance/session/5/title str "Sawfish"
+-edb_ed $DB add /entrance/session/5/icon str "default.png"
+-edb_ed $DB add /entrance/session/6/session str "xfce"
+-edb_ed $DB add /entrance/session/6/title str "XFce"
+-edb_ed $DB add /entrance/session/6/icon str "xfce.png"
+-edb_ed $DB add /entrance/session/7/session str "failsafe"
+-edb_ed $DB add /entrance/session/7/title str "Failsafe"
+-edb_ed $DB add /entrance/session/7/icon str "failsafe.png"
++edb_ed $DB add /entrance/session/1/session str "/etc/X11/Session/Enlightenment"
++#edb_ed $DB add /entrance/session/2/session str "kde"
++#edb_ed $DB add /entrance/session/2/title str "KDE"
++#edb_ed $DB add /entrance/session/2/icon str "kde.png"
++edb_ed $DB add /entrance/session/2/session str "/etc/X11/Session/GPE"
++edb_ed $DB add /entrance/session/2/title str "GPE"
++edb_ed $DB add /entrance/session/2/icon str "gnome.png"
++#edb_ed $DB add /entrance/session/4/session str "blackbox"
++#edb_ed $DB add /entrance/session/4/title str "Blackbox"
++#edb_ed $DB add /entrance/session/4/icon str "blackbox.png"
++#edb_ed $DB add /entrance/session/5/session str "sawfish"
++#edb_ed $DB add /entrance/session/5/title str "Sawfish"
++#edb_ed $DB add /entrance/session/5/icon str "default.png"
++#edb_ed $DB add /entrance/session/6/session str "xfce"
++#edb_ed $DB add /entrance/session/6/title str "XFce"
++#edb_ed $DB add /entrance/session/6/icon str "xfce.png"
++edb_ed $DB add /entrance/session/3/session str "/etc/X11/Session/Failsafe"
++edb_ed $DB add /entrance/session/3/title str "Failsafe"
++edb_ed $DB add /entrance/session/3/icon str "failsafe.png"
+ edb_ed $DB add /entrance/system/reboot int 1
+ edb_ed $DB add /entrance/system/halt int 1
+ edb_ed $DB add /entrance/user/remember int 1
diff --git a/packages/e17/entrance_20050810.bb b/packages/e17/entrance_20050810.bb
index 4a7bc20361..251698c233 100644
--- a/packages/e17/entrance_20050810.bb
+++ b/packages/e17/entrance_20050810.bb
@@ -3,15 +3,22 @@ SECTION = "e/apps"
 LICENSE = "MIT"
 # can also use pam and crypt
 DEPENDS = "edb evas-x11 ecore-x11 edje esmart"
+RDEPENDS += "bash"
 HOMEPAGE = "http://www.enlightenment.org"
 MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
 CVSDATE = "${PV}"
+PR = "r0"
 
 SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/entrance \
-           file://longer-sleep.patch;patch=1"
+           file://longer-sleep.patch;patch=1 \
+           file://Xserver.patch;patch=1 \
+           file://config-db.patch;patch=1 \
+           file://allow-missing-xsession.patch;patch=1"
 S = "${WORKDIR}/entrance"
 
 inherit autotools
 
-EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+                --with-xsession=/etc/X11/Xsession"
 
+FILES += "${datadir}"
\ No newline at end of file
-- 
cgit v1.2.3