From 8cf1c3a637603ef6640bf6d452b6b9927e86cd07 Mon Sep 17 00:00:00 2001
From: Shane Volpe <shanevolpe@gmail.com>
Date: Sat, 22 Sep 2007 22:03:10 +0000
Subject: Directfb-1.1.0:  Added Directfb Version 1.1.0

---
 packages/directfb/directfb_1.1.0.bb                | 57 ++++++++++++++++++++++
 .../directfb/files/fix-font-missing-char.patch     | 11 +++++
 packages/directfb/files/fix-pkgconfig-cflags.patch | 45 +++++++++++++++++
 3 files changed, 113 insertions(+)
 create mode 100644 packages/directfb/directfb_1.1.0.bb
 create mode 100644 packages/directfb/files/fix-font-missing-char.patch
 create mode 100644 packages/directfb/files/fix-pkgconfig-cflags.patch

(limited to 'packages/directfb')

diff --git a/packages/directfb/directfb_1.1.0.bb b/packages/directfb/directfb_1.1.0.bb
new file mode 100644
index 0000000000..bbda02e900
--- /dev/null
+++ b/packages/directfb/directfb_1.1.0.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "DirectFB is a thin library that provides developers \
+with hardware graphics acceleration, input device handling and \
+abstraction, an integrated windowing system with support for \
+translucent windows and multiple display layers on top of the \
+Linux framebuffer device."
+SECTION = "libs"
+LICENSE = "LGPL"
+HOMEPAGE = "http://directfb.org"
+DEPENDS = "jpeg libpng freetype zlib tslib"
+PR = "r0"
+RV = "1.1-0"
+
+SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-${PV}.tar.gz \
+           file://fix-pkgconfig-cflags.patch;patch=1 \
+	   file://fix-font-missing-char.patch;patch=1 \
+           file://getpagesize.patch;patch=1 \
+           file://fix-includes.patch;patch=1 \
+	   file://mkdfiff.patch;patch=1"
+
+S = "${WORKDIR}/DirectFB-${PV}"
+
+LDFLAGS_append =" -lts -lm"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-gfxdrivers=none \
+		--enable-libmpeg3=no \
+		--enable-freetype=yes \
+		--enable-sdl=no \
+		--disable-x11 \
+		"
+
+do_stage() {
+        autotools_stage_all
+}
+
+do_install() {
+        oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_directfb-dbg_append = " ${libdir}/directfb-${RV}/*/*/.debug/*.so \
+			      ${libdir}/directfb-${RV}/*/.debug/*.so \
+			  "
+
+FILES_directfb-dev_append = " ${libdir}/directfb-${RV}/systems/*.la \
+                              ${libdir}/directfb-${RV}/inputdrivers/*.la \
+                              ${libdir}/directfb-${RV}/interfaces/*/*.la \
+                              ${libdir}/directfb-${RV}/wm/*.la \
+			"
+
+
+FILES_directfb_append = " ${libdir}/directfb-${RV}/systems/*.so \
+                          ${libdir}/directfb-${RV}/inputdrivers/*.so \
+                          ${libdir}/directfb-${RV}/interfaces/*/*.so \
+                          ${libdir}/directfb-${RV}/wm/*.so \
+                          ${datadir}/directfb-1.1.0 \
+			  "
diff --git a/packages/directfb/files/fix-font-missing-char.patch b/packages/directfb/files/fix-font-missing-char.patch
new file mode 100644
index 0000000000..4c5e5883f4
--- /dev/null
+++ b/packages/directfb/files/fix-font-missing-char.patch
@@ -0,0 +1,11 @@
+--- git/src/media/idirectfbfont.c~org	2007-07-10 10:35:46.000000000 -0400
++++ git/src/media/idirectfbfont.c	2007-07-10 10:36:09.000000000 -0400
+@@ -497,7 +497,7 @@
+ 
+      if (width<max_width && string >= end) {
+           *ret_next_line = NULL;
+-          *ret_str_length = length-1;
++          *ret_str_length = length;
+           *ret_width = width;
+ 
+           return DFB_OK;
diff --git a/packages/directfb/files/fix-pkgconfig-cflags.patch b/packages/directfb/files/fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..0273b58ec5
--- /dev/null
+++ b/packages/directfb/files/fix-pkgconfig-cflags.patch
@@ -0,0 +1,45 @@
+diff -ur DirectFB-1.0.0~org/directfb-internal.pc.in DirectFB-1.0.0/directfb-internal.pc.in
+--- DirectFB-1.0.0~org/directfb-internal.pc.in	2003-07-04 13:30:22.000000000 -0400
++++ DirectFB-1.0.0/directfb-internal.pc.in	2007-03-16 22:34:17.000000000 -0400
+@@ -8,4 +8,4 @@
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}
+diff -ur DirectFB-1.0.0~org/directfb.pc.in DirectFB-1.0.0/directfb.pc.in
+--- DirectFB-1.0.0~org/directfb.pc.in	2004-08-04 12:28:20.000000000 -0400
++++ DirectFB-1.0.0/directfb.pc.in	2007-03-16 22:31:33.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/direct/direct.pc.in DirectFB-1.0.0/lib/direct/direct.pc.in
+--- DirectFB-1.0.0~org/lib/direct/direct.pc.in	2005-11-23 09:18:59.000000000 -0500
++++ DirectFB-1.0.0/lib/direct/direct.pc.in	2007-03-16 22:32:13.000000000 -0400
+@@ -7,4 +7,4 @@
+ Description: DirectFB base development library
+ Version: @VERSION@
+ Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/fusion/fusion.pc.in DirectFB-1.0.0/lib/fusion/fusion.pc.in
+--- DirectFB-1.0.0~org/lib/fusion/fusion.pc.in	2004-05-19 07:30:56.000000000 -0400
++++ DirectFB-1.0.0/lib/fusion/fusion.pc.in	2007-03-16 22:32:34.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+--- DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in	2004-05-19 07:31:28.000000000 -0400
++++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in	2007-03-16 22:32:55.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}
-- 
cgit v1.2.3