From 88f473fa5bb4c6f8c62feebc4e19547faade0218 Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@openembedded.org>
Date: Fri, 24 Nov 2006 19:27:48 +0000
Subject: btsco: stop configure from putting -I/usr/include into the commmand
 line, fixes the problems people where seeing in #oe * config.log is a handy
 debug tool

---
 packages/btsco/btsco_0.42.bb | 10 ++++++++++
 1 file changed, 10 insertions(+)

(limited to 'packages/btsco')

diff --git a/packages/btsco/btsco_0.42.bb b/packages/btsco/btsco_0.42.bb
index 005f3715f5..a4dd11b197 100644
--- a/packages/btsco/btsco_0.42.bb
+++ b/packages/btsco/btsco_0.42.bb
@@ -9,3 +9,13 @@ inherit autotools pkgconfig
 SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz"
 
 S = "${WORKDIR}/${PN}-${PV}"
+
+CFLAGS += " -I${STAGING_INCDIR} "
+
+#there are some bogus macros putting -I/usr/include into C(PP)FLAGS, lets fix that
+do_configure() {
+	libtoolize --force
+	gnu-configize 
+	sed -i 's:-I${bluez_prefix}/include::g' configure
+	oe_runconf
+}	
-- 
cgit v1.2.3