From 4f542541f9f486922375d1ea299642c22c1f08b2 Mon Sep 17 00:00:00 2001
From: Philipp Zabel <philipp.zabel@gmail.com>
Date: Thu, 12 Jan 2006 21:35:55 +0000
Subject: blueprobe: add h6300 and hx4700 support to 0.16

---
 packages/blueprobe/blueprobe-0.16/.mtn2git_empty |  0
 packages/blueprobe/blueprobe-0.16/h6300.patch    | 17 ++++++++++++++
 packages/blueprobe/blueprobe-0.16/hx4700.patch   | 30 ++++++++++++++++++++++++
 packages/blueprobe/blueprobe_0.16.bb             |  4 ++++
 4 files changed, 51 insertions(+)
 create mode 100644 packages/blueprobe/blueprobe-0.16/.mtn2git_empty
 create mode 100644 packages/blueprobe/blueprobe-0.16/h6300.patch
 create mode 100644 packages/blueprobe/blueprobe-0.16/hx4700.patch

(limited to 'packages/blueprobe')

diff --git a/packages/blueprobe/blueprobe-0.16/.mtn2git_empty b/packages/blueprobe/blueprobe-0.16/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
diff --git a/packages/blueprobe/blueprobe-0.16/h6300.patch b/packages/blueprobe/blueprobe-0.16/h6300.patch
new file mode 100644
index 0000000000..39de7758b0
--- /dev/null
+++ b/packages/blueprobe/blueprobe-0.16/h6300.patch
@@ -0,0 +1,17 @@
+diff -Naur blueprobe-0.15_orig/blueprobe.init blueprobe-0.15_h6300_fix/blueprobe.init
+--- blueprobe-0.15_orig/blueprobe.init	2005-10-05 22:37:35.706302041 +0300
++++ blueprobe-0.15_h6300_fix/blueprobe.init	2005-10-05 22:54:51.840676832 +0300
+@@ -57,6 +57,13 @@
+ 	SCRIPT=/etc/bluetooth/TIInit_3.2.26.bts
+ 	PROBE=no
+ 	;;
++    "HP iPAQ H6300")
++	BLUETOOTH=yes
++	PORT=/dev/ttyS0
++	SPEED=115200
++	PROTO=texas
++	PROBE=no
++	;;
+     *)
+ 	BLUETOOTH=no
+         ;;
diff --git a/packages/blueprobe/blueprobe-0.16/hx4700.patch b/packages/blueprobe/blueprobe-0.16/hx4700.patch
new file mode 100644
index 0000000000..69610e8c7b
--- /dev/null
+++ b/packages/blueprobe/blueprobe-0.16/hx4700.patch
@@ -0,0 +1,30 @@
+--- blueprobe-0.14/blueprobe.init.orig	2005-09-05 22:03:57 +0200
++++ blueprobe-0.14/blueprobe.init	2005-09-05 22:09:34 +0200
+@@ -47,6 +47,18 @@
+         PROTO=bcsp
+ 	PROBE=yes
+ 	;;
++    "HP iPAQ HX4700")
++	BLUETOOTH=yes
++	PORT=/dev/ttyS1
++	PROTO=texas
++	SCRIPT=/etc/bluetooth/TIInit_3.2.26.bts
++	if [ -f "$SCRIPT" ]; then
++		SPEED=921600
++	else
++		SPEED=115200
++	fi
++	PROBE=no
++	;;
+     *)
+ 	BLUETOOTH=no
+         ;;
+@@ -67,5 +75,8 @@
+     echo "BLUETOOTH_PORT=$PORT" >>/etc/sysconfig/bluetooth
+     echo "BLUETOOTH_SPEED=$SPEED" >>/etc/sysconfig/bluetooth
+     echo "BLUETOOTH_PROTOCOL=$PROTO" >>/etc/sysconfig/bluetooth
++    if [ "$SCRIPT" != "" ] && [ -f "$SCRIPT" ]; then
++      echo "BLUETOOTH_SCRIPT=$SCRIPT" >>/etc/sysconfig/bluetooth
++    fi
+   fi
+ fi
diff --git a/packages/blueprobe/blueprobe_0.16.bb b/packages/blueprobe/blueprobe_0.16.bb
index e54d2ed066..7ec102d0eb 100644
--- a/packages/blueprobe/blueprobe_0.16.bb
+++ b/packages/blueprobe/blueprobe_0.16.bb
@@ -2,3 +2,7 @@ SECTION = "base"
 LICENSE = "GPL"
 inherit gpe
 
+PR = "r1"
+
+SRC_URI += "file://hx4700.patch;patch=1 \
+	    file://h6300.patch;patch=1"
-- 
cgit v1.2.3