summaryrefslogtreecommitdiff
path: root/recipes/vlan/vlan_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vlan/vlan_1.9.bb')
-rw-r--r--recipes/vlan/vlan_1.9.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/recipes/vlan/vlan_1.9.bb b/recipes/vlan/vlan_1.9.bb
index 3a10e898ab..a4f5e5a56c 100644
--- a/recipes/vlan/vlan_1.9.bb
+++ b/recipes/vlan/vlan_1.9.bb
@@ -4,8 +4,12 @@ PR = "r0"
S = "${WORKDIR}/vlan/"
-SRC_URI = "http://www.candelatech.com/~greear/vlan/vlan.${PV}.tar.gz \
- "
+SRC_URI = " \
+ http://www.candelatech.com/~greear/vlan/vlan.${PV}.tar.gz \
+ file://ip \
+ file://vlan-pre-up \
+ file://vlan-post-down \
+ "
inherit base
@@ -20,5 +24,11 @@ do_compile() {
do_install() {
install -d "${D}${sbindir}"
install -m 755 "${S}/vconfig" "${D}${sbindir}/vconfig"
+ install -d ${D}/${sysconfdir}/network/if-pre-up.d
+ install -d ${D}/${sysconfdir}/network/if-post-down.d
+ install -d ${D}/${sysconfdir}/network/if-up.d
+ install -m 0755 ${WORKDIR}/ip ${D}/${sysconfdir}/network/if-up.d/
+ install -m 0755 ${WORKDIR}/vlan-pre-up ${D}/${sysconfdir}/network/if-pre-up.d/vlan
+ install -m 0755 ${WORKDIR}/vlan-post-down ${D}/${sysconfdir}/network/if-post-down.d/vlan
}