summaryrefslogtreecommitdiff
path: root/recipes/ti/ti-dspbios-native_5.33.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/ti-dspbios-native_5.33.04.bb')
-rw-r--r--recipes/ti/ti-dspbios-native_5.33.04.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/ti/ti-dspbios-native_5.33.04.bb b/recipes/ti/ti-dspbios-native_5.33.04.bb
new file mode 100644
index 0000000000..d5667f04dd
--- /dev/null
+++ b/recipes/ti/ti-dspbios-native_5.33.04.bb
@@ -0,0 +1,22 @@
+require ti-dspbios.inc
+inherit native
+
+# download bios_setuplinux_5_33_04.bin from https://www-a.ti.com/downloads/sds_support/targetcontent/bios/bios_5_33/bios_5_33_04/index_external.html and copy in Arago (or OE) installation directory
+
+SRC_URI = "http://install.source.dir.com/bios_setuplinux_5_33_04.bin"
+BINFILE="bios_setuplinux_5_33_04.bin"
+
+S = "${WORKDIR}/bios_5_33_04"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "5334"
+PR = "r2"
+
+do_stage() {
+ install -d ${STAGING_DIR_NATIVE}/${PN}
+ cp -pPrf ${S}/* ${STAGING_DIR_NATIVE}/${PN}/
+ chmod 755 -R ${STAGING_DIR_NATIVE}/${PN}/*
+}
+
+AUTOTOOLS_NATIVE_STAGE_INSTALL="1"
+