summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-sgh-i900_2.6.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-sgh-i900_2.6.29.bb')
-rw-r--r--recipes/linux/linux-sgh-i900_2.6.29.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/linux/linux-sgh-i900_2.6.29.bb b/recipes/linux/linux-sgh-i900_2.6.29.bb
new file mode 100644
index 0000000000..5bd2f4f0f3
--- /dev/null
+++ b/recipes/linux/linux-sgh-i900_2.6.29.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Linux 2.6.29 kernel for the Samsung Omnia SGH-i900."
+SECTION = "kernel"
+LICENSE = "GPL"
+
+RDEPENDS += "marvell-gspi-fw"
+
+COMPATIBLE_MACHINE = "sgh-i900"
+
+SRC_URI = "git://andromnia.git.sourceforge.net/gitroot/andromnia/andromnia;protocol=git;branch=master \
+ file://wm97xx-ts-fix.patch;patch=1 \
+ file://sgh_i900_defconfig"
+
+S = "${WORKDIR}/git"
+
+inherit kernel
+
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/sgh_i900_defconfig ${S}/.config
+}