summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/gpe-conf/gpe-conf-0.2.7/.mtn2git_empty0
-rw-r--r--packages/gpe-conf/gpe-conf-0.2.7/poweroff.patch11
-rw-r--r--packages/gpe-conf/gpe-conf_0.2.7.bb4
3 files changed, 14 insertions, 1 deletions
diff --git a/packages/gpe-conf/gpe-conf-0.2.7/.mtn2git_empty b/packages/gpe-conf/gpe-conf-0.2.7/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-conf/gpe-conf-0.2.7/.mtn2git_empty
diff --git a/packages/gpe-conf/gpe-conf-0.2.7/poweroff.patch b/packages/gpe-conf/gpe-conf-0.2.7/poweroff.patch
new file mode 100644
index 0000000000..2255886968
--- /dev/null
+++ b/packages/gpe-conf/gpe-conf-0.2.7/poweroff.patch
@@ -0,0 +1,11 @@
+--- gpe-conf/suid.c~ 2008-06-05 12:41:26.000000000 +0200
++++ gpe-conf/suid.c 2008-06-05 12:41:26.000000000 +0200
+@@ -454,7 +454,7 @@
+ else if (strcmp (cmd, "SHDN") == 0) // shutdown device
+ {
+ fscanf (in, "%100s", arg2);
+- system ("poweroff");
++ system ("/sbin/poweroff");
+ }
+ else if (strcmp (cmd, "MODP") == 0) /* modprobe kernel module */
+ {
diff --git a/packages/gpe-conf/gpe-conf_0.2.7.bb b/packages/gpe-conf/gpe-conf_0.2.7.bb
index b908e6c50b..ec836eb068 100644
--- a/packages/gpe-conf/gpe-conf_0.2.7.bb
+++ b/packages/gpe-conf/gpe-conf_0.2.7.bb
@@ -10,12 +10,14 @@ RDEPENDS_gpe-conf-panel = "gpe-conf"
RPROVIDES_${PN} += " bl"
RCONFLICTS_${PN} = "bl"
-PR = "r0"
+PR = "r1"
GPE_TARBALL_SUFFIX = "bz2"
inherit gpe autotools pkgconfig
+SRC_URI += "file://poweroff.patch;patch=1"
+
PACKAGES += "gpe-conf-panel"
FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \