summaryrefslogtreecommitdiff
path: root/packages/squashfs-tools
diff options
context:
space:
mode:
Diffstat (limited to 'packages/squashfs-tools')
-rw-r--r--packages/squashfs-tools/files/squashfs2.0-tools-lzma.patch0
-rw-r--r--packages/squashfs-tools/squashfs-tools-native_2.0r2.bb12
-rw-r--r--packages/squashfs-tools/squashfs-tools_2.0r2.bb9
3 files changed, 20 insertions, 1 deletions
diff --git a/packages/squashfs-tools/files/squashfs2.0-tools-lzma.patch b/packages/squashfs-tools/files/squashfs2.0-tools-lzma.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/squashfs-tools/files/squashfs2.0-tools-lzma.patch
diff --git a/packages/squashfs-tools/squashfs-tools-native_2.0r2.bb b/packages/squashfs-tools/squashfs-tools-native_2.0r2.bb
index e69de29bb2..569bf8dad2 100644
--- a/packages/squashfs-tools/squashfs-tools-native_2.0r2.bb
+++ b/packages/squashfs-tools/squashfs-tools-native_2.0r2.bb
@@ -0,0 +1,12 @@
+SECTION = "base"
+PN_BASE = "squashfs-tools"
+include ${PN_BASE}_${PV}.bb
+inherit native
+
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/${PN_BASE}-${PV}', '${FILE_DIRNAME}/${PN_BASE}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+PACKAGES = ""
+
+do_stage () {
+ install -m 0755 mksquashfs ${STAGING_BINDIR}/
+ install -m 0755 mksquashfs-lzma ${STAGING_BINDIR}/
+}
diff --git a/packages/squashfs-tools/squashfs-tools_2.0r2.bb b/packages/squashfs-tools/squashfs-tools_2.0r2.bb
index 601724a5cb..f99cdb798e 100644
--- a/packages/squashfs-tools/squashfs-tools_2.0r2.bb
+++ b/packages/squashfs-tools/squashfs-tools_2.0r2.bb
@@ -4,12 +4,19 @@ MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
LICENSE = "GPLv2"
SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz \
- file://flags.patch;patch=1"
+ file://flags.patch;patch=1 \
+ file://squashfs2.0-tools-lzma.patch;patch=1"
S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
prefix = ""
+do_compile() {
+ oe_runmake
+ oe_runmake mksquashfs-lzma
+}
+
do_install () {
install -d ${D}${sbindir}
install -m 0755 mksquashfs ${D}${sbindir}/
+ install -m 0755 mksquashfs-lzma ${D}${sbindir}/
}