summaryrefslogtreecommitdiff
path: root/packages/pulseaudio/pulseaudio_0.9.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/pulseaudio/pulseaudio_0.9.5.bb')
-rw-r--r--packages/pulseaudio/pulseaudio_0.9.5.bb39
1 files changed, 36 insertions, 3 deletions
diff --git a/packages/pulseaudio/pulseaudio_0.9.5.bb b/packages/pulseaudio/pulseaudio_0.9.5.bb
index b6209143f0..9fdd3aa235 100644
--- a/packages/pulseaudio/pulseaudio_0.9.5.bb
+++ b/packages/pulseaudio/pulseaudio_0.9.5.bb
@@ -10,10 +10,13 @@ DEPENDS += "alsa-lib"
RPROVIDES = "esound esd"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://0pointer.de/lennart/projects/pulseaudio/pulseaudio-${PV}.tar.gz"
+SRC_URI += "file://volatiles.04_pulse"
+
+
inherit autotools pkgconfig
EXTRA_OECONF = "\
@@ -27,19 +30,49 @@ EXTRA_OECONF = "\
PARALLEL_MAKE = ""
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/default/volatiles
+ install -m 0644 ${WORKDIR}/volatiles.04_pulse ${D}${sysconfdir}/default/volatiles/volatiles.04_pulse
+}
+
+
LEAD_SONAME = "libpulse.so"
-PACKAGES =+ "${PN}-conf ${PN}-bin"
+PACKAGES =+ "${PN}-bin ${PN}-conf"
PACKAGES_DYNAMIC = "pulseaudio-module-* pulseaudio-lib-*"
FILES_${PN}-conf = "${sysconfdir}"
-FILES_${PN}-bin = "${bindir}/*"
+FILES_${PN}-bin = "${bindir}/* \
+ ${sysconfdir}/default/volatiles/volatiles.04_pulse"
CONFFILES_${PN}-conf = "\
${sysconfdir}/pulse/default.pa \
${sysconfdir}/pulse/daemon.conf \
${sysconfdir}/pulse/client.conf \
"
+pkg_postinst_${PN}-bin() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ grep -q pulse: /etc/group || addgroup pulse
+ grep -q pulse: /etc/passwd || \
+ adduser --disabled-password --home=/var/run/pulse/ --system \
+ --ingroup pulse --no-create-home -g "Pulse audio daemon" pulse
+ /etc/init.d/populate-volatile.sh update
+fi
+}
+
+pkg_postrm${PN}-bin() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ deluser pulse
+fi
+}
+
+
+
do_stage() {
autotools_stage_all