summaryrefslogtreecommitdiff
path: root/packages/oprofile/oprofile_0.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/oprofile/oprofile_0.9.3.bb')
-rw-r--r--packages/oprofile/oprofile_0.9.3.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/packages/oprofile/oprofile_0.9.3.bb b/packages/oprofile/oprofile_0.9.3.bb
index d758b97549..977907e305 100644
--- a/packages/oprofile/oprofile_0.9.3.bb
+++ b/packages/oprofile/oprofile_0.9.3.bb
@@ -1,11 +1,15 @@
-SECTION = "devel"
DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
of profiling all running code at low overhead."
+SECTION = "devel"
LICENSE = "GPL"
DEPENDS = "popt binutils"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
- file://acinclude.m4"
+ file://acinclude.m4 \
+ file://opcontrol-busybox-compat.patch;patch=1 \
+ "
+
S = "${WORKDIR}/oprofile-${PV}"
inherit autotools
@@ -14,12 +18,12 @@ inherit autotools
# Should add the oprofile kernel modules, for those with 2.4
# kernels, as a seperate .oe file.
EXTRA_OECONF = "--with-kernel-support \
- --without-x \
- --disable-werror "
+ --without-x \
+ --disable-werror "
do_configure () {
- cp ${WORKDIR}/acinclude.m4 ${S}/
- autotools_do_configure
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
}
# Available config options
# --enable-abi enable abi portability code (default is disabled)