summaryrefslogtreecommitdiff
path: root/packages/neuros-public/neuros-nwm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/neuros-public/neuros-nwm_git.bb')
-rw-r--r--packages/neuros-public/neuros-nwm_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/neuros-public/neuros-nwm_git.bb b/packages/neuros-public/neuros-nwm_git.bb
new file mode 100644
index 0000000000..6dbbd4cabd
--- /dev/null
+++ b/packages/neuros-public/neuros-nwm_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Neuros window manager"
+LICENSE = "GPL"
+
+PV = "0.0+${PR}+gitr${SRCREV}"
+PR = "r2"
+
+DEPENDS = "qt-embedded"
+
+inherit qtopia4core
+
+SRCREV = "d0b6789dde38d321d3c90c04512a4ea43e28e79e"
+SRC_URI = "git://git.neurostechnology.com/git/app-nwm;protocol=git"
+S = "${WORKDIR}/git/"
+
+do_configure_prepend() {
+ rm ${S}/src/Makefile || true
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/build/nwm ${D}/${bindir}
+}