summaryrefslogtreecommitdiff
path: root/packages/neuros-public/neuros-nwm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/neuros-public/neuros-nwm_git.bb')
-rw-r--r--packages/neuros-public/neuros-nwm_git.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/packages/neuros-public/neuros-nwm_git.bb b/packages/neuros-public/neuros-nwm_git.bb
index 0f0dcf857d..bf4bbaa9af 100644
--- a/packages/neuros-public/neuros-nwm_git.bb
+++ b/packages/neuros-public/neuros-nwm_git.bb
@@ -2,18 +2,23 @@ DESCRIPTION = "Neuros window manager"
LICENSE = "GPL"
PV = "0.0+${PR}+gitr${SRCREV}"
-PR = "r4"
+PR = "r5"
DEPENDS = "qt-embedded"
-inherit qtopia4core
+inherit qtopia4core update-rc.d
SRCREV = "e6c30ba6e5be217ca4bf7e98e00f87bb7241872c"
-SRC_URI = "git://git.neurostechnology.com/git/app-nwm;protocol=git"
+SRC_URI = "git://git.neurostechnology.com/git/app-nwm;protocol=git \
+ file://init"
+
+INITSCRIPT_NAME = "neuros-nwm"
+
S = "${WORKDIR}/git/"
do_configure_prepend() {
rm ${S}/src/Makefile || true
+ sed -i -e s:/usr/locl/bin:${bindir}:g ${WORKDIR}/init
}
do_install() {
@@ -21,6 +26,9 @@ do_install() {
install -m 0755 ${S}/build/nwm ${D}/${bindir}
install -d ${D}/${libdir}
ln -sf ${datadir}/fonts ${D}/${libdir}/fonts
+
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/neuros-nwm
}
FILES_${PN} += "${libdir}/fonts"