summaryrefslogtreecommitdiff
path: root/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb')
-rw-r--r--packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
index e69de29bb2..d4fc63d6b9 100644
--- a/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
+++ b/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
+DEPENDS = "matchbox xmodmap"
+SRC_URI = "file://xrandr-panelapp.sh \
+ file://xrandr-panelapp.desktop \
+ file://xrandr.png"
+SECTION = "x11/wm"
+PRIORITY = "optional"
+PR = "r1"
+LICENSE = "MIT"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}/${bindir}/
+ install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}/${datadir}/applications/
+ install -m 0644 ${WORKDIR}/xrandr.png ${D}/${datadir}/pixmaps/
+}