summaryrefslogtreecommitdiff
path: root/packages/man/man_1.5p.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/man/man_1.5p.bb')
-rw-r--r--packages/man/man_1.5p.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/man/man_1.5p.bb b/packages/man/man_1.5p.bb
new file mode 100644
index 0000000000..c666cf6c9c
--- /dev/null
+++ b/packages/man/man_1.5p.bb
@@ -0,0 +1,34 @@
+LICENSE = "GPL"
+SECTION = "base"
+MAINTAINER = "Inge Arnesen <inge.arnesen@gmail.com>"
+DESCRIPTION = "The man page suite, including man, apropos, \
+and whatis consists of programs that are used to read most \
+of the documentation available on a Linux system."
+RDEPENDS="less groff"
+# Note: The default man.conf uses wrong names for GNU eqn and troff,
+# so we install our own
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/man/man-${PV}.tar.bz2 \
+ file://man.conf"
+
+EXTRA_OEMAKE = ""
+GS = "-DGREPSILENT=\"q\""
+DEFS = "-DUSG -DDO_COMPRESS ${GS}"
+
+do_configure() {
+ ./configure -d -confdir ${sysconfdir}
+}
+
+do_compile() {
+ (cd src; ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
+ makemsg.c -o makemsg)
+ oe_runmake 'DEFS=${DEFS}'
+}
+
+do_install() {
+ oe_runmake 'PREFIX=${D}' install
+ install -m 644 ${FILESDIR}/man.conf ${D}/etc
+}
+
+FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
+ ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ /bin /sbin /lib/*/ /lib/*.so*"