summaryrefslogtreecommitdiff
path: root/packages/maemo
diff options
context:
space:
mode:
Diffstat (limited to 'packages/maemo')
-rw-r--r--packages/maemo/osso-core-config_200515.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/maemo/osso-core-config_200515.1.bb b/packages/maemo/osso-core-config_200515.1.bb
index e69de29bb2..1010e91e8a 100644
--- a/packages/maemo/osso-core-config_200515.1.bb
+++ b/packages/maemo/osso-core-config_200515.1.bb
@@ -0,0 +1,41 @@
+LICENSE = "unknown"
+MAINTAINER= "Florian Boor <florian@kernelconcepts.de"
+PR = "r4"
+
+DEPENDS = "base-passwd osso-af-startup"
+RDEPENDS = "base-passwd osso-af-startup"
+
+SRC_URI = "http://stage.maemo.org:80/pool/maemo/ossw/source/o/${PN}/${PN}_${PV}.tar.gz"
+
+
+inherit autotools update-rc.d
+
+FILES_${PN} = "${sysconfdir}/osso-af-init ${sysconfdir}/init.d/"
+
+INITSCRIPT_NAME = "x-server.sh"
+INITSCRIPT_PARAMS = "defaults 21"
+
+
+do_install () {
+ install -d ${D}${sysconfdir}/osso-af-init
+ install -m 755 ${S}/x-server.defs ${D}/${sysconfdir}/osso-af-init/x-server.defs
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${S}/x-server.sh ${D}/${sysconfdir}/init.d/x-server.sh
+}
+
+pkg_postinst () {
+#!/bin/sh
+
+# can't do adduser stuff offline
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+MAEMOUSER=user
+MAEMOHOME=/home/user
+
+mkdir -p $MAEMOHOME/MyDocs || true
+chgrp "$MAEMOUSER" "$MAEMOHOME" 2>/dev/null || addgroup "$MAEMOUSER"
+adduser --system --home "$MAEMOHOME" --no-create-home --disabled-password --ingroup "$MAEMOUSER" "$MAEMOUSER" || chown -R "$MAEMOUSER"."$MAEMOUSER" "$MAEMOHOME" 2>/dev/null
+}