summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-2.6.26/boc01/012-081218-cy3218-btns.patch (renamed from packages/linux/linux-2.6.26/boc01/012-081121-cy3218-btns.patch)24
-rw-r--r--packages/linux/linux-openmoko-devel/defconfig-oe9
-rw-r--r--packages/linux/linux-openmoko-devel_git.bb2
-rw-r--r--packages/linux/linux-openmoko.inc9
-rw-r--r--packages/linux/linux-openmoko_2.6.24+git.bb2
-rw-r--r--packages/linux/linux_2.6.26.bb4
6 files changed, 31 insertions, 19 deletions
diff --git a/packages/linux/linux-2.6.26/boc01/012-081121-cy3218-btns.patch b/packages/linux/linux-2.6.26/boc01/012-081218-cy3218-btns.patch
index 51d092c528..d5985f3f0a 100644
--- a/packages/linux/linux-2.6.26/boc01/012-081121-cy3218-btns.patch
+++ b/packages/linux/linux-2.6.26/boc01/012-081218-cy3218-btns.patch
@@ -70,11 +70,11 @@ diff -Nru linux-2.6.26.orig/drivers/input/misc/cy3218-btns.c linux-2.6.26/driver
+}
+
+unsigned short keymap[5] = {
-+ KEY_A,
-+ KEY_B,
-+ KEY_C,
-+ KEY_D,
-+ KEY_E,
++ KEY_UP,
++ KEY_F1,
++ KEY_ENTER,
++ KEY_DOWN,
++ KEY_BACKSPACE,
+};
+
+static void handle_buttons(struct input_polled_dev *dev)
@@ -89,7 +89,7 @@ diff -Nru linux-2.6.26.orig/drivers/input/misc/cy3218-btns.c linux-2.6.26/driver
+ if(uValue == MASK0)
+ {
+ report_key(idev, keymap[0]);
-+ printk("Bouton A\n");
++ printk("Bouton UP\n");
+ }
+
+ uValue = i2c_smbus_read_byte_data(&capsense->client, CAP_STATE_GP0);
@@ -97,24 +97,24 @@ diff -Nru linux-2.6.26.orig/drivers/input/misc/cy3218-btns.c linux-2.6.26/driver
+ if(uValue == MASK0)
+ {
+ report_key(idev, keymap[1]);
-+ printk("Bouton E\n");
++ printk("Bouton HELP\n");
+ }
+
+ if(uValue == MASK1)
+ {
+ report_key(idev, keymap[2]);
-+ printk("Bouton B\n");
++ printk("Bouton OK\n");
+ }
+
+ if(uValue == MASK2)
+ {
+ report_key(idev, keymap[3]);
-+ printk("Bouton C\n");
++ printk("Bouton DOWN\n");
+ }
+ if(uValue == MASK3)
+ {
+ report_key(idev, keymap[4]);
-+ printk("Bouton D\n");
++ printk("Bouton BACK\n");
+ }
+}
+
@@ -167,8 +167,8 @@ diff -Nru linux-2.6.26.orig/drivers/input/misc/cy3218-btns.c linux-2.6.26/driver
+ set_bit(EV_KEY, ipdev->input->evbit);
+
+
-+ for (i = 0; i < 3; i++)
-+ set_bit(keymap[i], ipdev->input->keybit);
++ for (i = 0; i < ARRAY_SIZE(keymap); i++)
++ set_bit(keymap[i], ipdev->input->keybit);
+
+ rc = input_register_polled_device(ipdev);
+ if(rc)
diff --git a/packages/linux/linux-openmoko-devel/defconfig-oe b/packages/linux/linux-openmoko-devel/defconfig-oe
index b5d7e2f4df..32bcb9a52d 100644
--- a/packages/linux/linux-openmoko-devel/defconfig-oe
+++ b/packages/linux/linux-openmoko-devel/defconfig-oe
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.28-rc4
-# Sun Dec 14 16:59:01 2008
+# Thu Dec 18 22:58:51 2008
#
CONFIG_ARM=y
CONFIG_HAVE_PWM=y
@@ -1823,7 +1823,11 @@ CONFIG_ROMFS_FS=y
# CONFIG_SYSV_FS is not set
# CONFIG_UFS_FS is not set
CONFIG_NETWORK_FILESYSTEMS=y
-# CONFIG_NFS_FS is not set
+CONFIG_NFS_FS=y
+CONFIG_NFS_V3=y
+CONFIG_NFS_V3_ACL=y
+# CONFIG_NFS_V4 is not set
+CONFIG_ROOT_NFS=y
CONFIG_NFSD=y
CONFIG_NFSD_V2_ACL=y
CONFIG_NFSD_V3=y
@@ -1843,6 +1847,7 @@ CONFIG_CIFS=m
# CONFIG_CIFS_STATS is not set
# CONFIG_CIFS_WEAK_PW_HASH is not set
# CONFIG_CIFS_XATTR is not set
+# CONFIG_CIFS_POSIX is not set
# CONFIG_CIFS_DEBUG2 is not set
# CONFIG_CIFS_EXPERIMENTAL is not set
# CONFIG_NCP_FS is not set
diff --git a/packages/linux/linux-openmoko-devel_git.bb b/packages/linux/linux-openmoko-devel_git.bb
index d3f5d3fdfe..91cae5cb97 100644
--- a/packages/linux/linux-openmoko-devel_git.bb
+++ b/packages/linux/linux-openmoko-devel_git.bb
@@ -8,7 +8,7 @@ DEFAULT_PREFERENCE = "-1"
KERNEL_RELEASE = "2.6.27"
KERNEL_VERSION = "${KERNEL_RELEASE}"
-OEV = "oe2"
+OEV = "oe3"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
PR = "r0"
diff --git a/packages/linux/linux-openmoko.inc b/packages/linux/linux-openmoko.inc
index c986975851..278a01d5ee 100644
--- a/packages/linux/linux-openmoko.inc
+++ b/packages/linux/linux-openmoko.inc
@@ -56,9 +56,14 @@ do_deploy_append() {
RDEPENDS_kernel-image += "mtd-utils"
pkg_postinst_kernel-image () {
+
+# Get the lastest root file system value of boot args
+boot_arg=`cat /proc/cmdline |tr " " "\n"|grep "root=" |tail -n 1`
+has_mtdblock=`echo $boot_arg |grep mtdblock`
+
if test "x$D" != "x"; then
exit 1
-else
+elif test "empty$has_mtdblock" != "empty"; then
if [ -f ${sysconfdir}/default/flashkernel ] ; then
echo "Upgrading Kernel in Flash"
echo "DO NOT stop this process"
@@ -79,6 +84,8 @@ else
else
touch ${sysconfdir}/default/flashkernel
fi
+else
+ echo "You are not booting from NAND, don't flash kernel into mtdblock."
fi
}
diff --git a/packages/linux/linux-openmoko_2.6.24+git.bb b/packages/linux/linux-openmoko_2.6.24+git.bb
index 6f62b3dbdf..48b7effd55 100644
--- a/packages/linux/linux-openmoko_2.6.24+git.bb
+++ b/packages/linux/linux-openmoko_2.6.24+git.bb
@@ -8,7 +8,7 @@ KERNEL_VERSION = "${KERNEL_RELEASE}"
OEV = "oe3"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \
diff --git a/packages/linux/linux_2.6.26.bb b/packages/linux/linux_2.6.26.bb
index c3fa981292..d15b22098d 100644
--- a/packages/linux/linux_2.6.26.bb
+++ b/packages/linux/linux_2.6.26.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r4"
+PR = "r5"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
@@ -23,7 +23,7 @@ SRC_URI_append_boc01 = "\
file://008-081127-spi.patch;patch=1 \
file://010-081105-mii.patch;patch=1 \
file://011-081202-gpio.patch;patch=1 \
- file://012-081121-cy3218-btns.patch;patch=1 \
+ file://012-081218-cy3218-btns.patch;patch=1 \
file://013-081212-lcd.patch;patch=1 \
"