summaryrefslogtreecommitdiff
path: root/packages/gallery/gallery_1.5.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gallery/gallery_1.5.5.bb')
-rw-r--r--packages/gallery/gallery_1.5.5.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/packages/gallery/gallery_1.5.5.bb b/packages/gallery/gallery_1.5.5.bb
index 5756e98567..14c7c0f4e0 100644
--- a/packages/gallery/gallery_1.5.5.bb
+++ b/packages/gallery/gallery_1.5.5.bb
@@ -2,21 +2,21 @@ DESCRIPTION = "The Gallery v1 web image gallery"
SECTION = "apps"
LICENSE = "GPL"
RDEPENDS = "apache2 modphp imagemagick jhead"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://easynews.dl.sourceforge.net/sourceforge/gallery/gallery-${PV}-pl1.tar.gz"
+SRC_URI = "http://{SOURCEFORGE_MIRROR}/sourceforge/gallery/gallery-${PV}-pl1.tar.gz"
S = "${WORKDIR}/gallery"
inherit autotools
-HTTPCONF = "/etc/apache2/httpd.conf"
-DEST_DIR = "/usr/share/apache2/htdocs/"
+HTTPCONF = "${sysconfdir}/apache2/httpd.conf"
+DEST_DIR = "${datadir}/apache2/htdocs/"
#
# don't list the albums as a file - it might get auto-deleted
#
-FILES_${PN} = "${DEST_DIR}/gallery /etc/apache2/modules.d"
+FILES_${PN} = "${DEST_DIR}/gallery ${sysconfdir}/apache2/modules.d"
# No configure step for gallery
@@ -31,12 +31,12 @@ do_compile() {
#
do_install() {
- mkdir -p ${D}/${DEST_DIR} ${D}/etc/apache2/modules.d
+ mkdir -p ${D}/${DEST_DIR} ${D}${sysconfdir}/apache2/modules.d
cp -pPR ${S} ${D}/${DEST_DIR}
- cp ${FILESDIR}/gallery.conf ${D}/etc/apache2/modules.d/95_gallery.conf
+ cp ${FILESDIR}/gallery.conf ${D}${sysconfdir}/apache2/modules.d/95_gallery.conf
}
# remove the gallery code, but not the albums!
pkg_postrm_${PN}() {
- rm -rf ${DEST_DIR}/gallery /etc/apache2/modules.d/95_gallery.conf
+ rm -rf ${DEST_DIR}/gallery /${sysconfdir}/apache2/modules.d/95_gallery.conf
}