summaryrefslogtreecommitdiff
path: root/packages/dbus
diff options
context:
space:
mode:
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-1.0.2/dbus-1.init20
-rw-r--r--packages/dbus/dbus-glib-0.72/cross.patch12
-rw-r--r--packages/dbus/dbus-glib-0.74/.mtn2git_empty (renamed from packages/dbus/dbus-glib-0.72/.mtn2git_empty)0
-rw-r--r--packages/dbus/dbus-glib-0.74/no-examples.patch (renamed from packages/dbus/dbus-glib/no-examples.patch)0
-rw-r--r--packages/dbus/dbus-glib-0.74/no-introspect.patch (renamed from packages/dbus/dbus-glib-0.72/no-introspect.patch)15
-rw-r--r--packages/dbus/dbus-glib-native-0.74/.mtn2git_empty (renamed from packages/dbus/dbus-glib-native-0.72/.mtn2git_empty)0
-rw-r--r--packages/dbus/dbus-glib-native-0.74/run-with-tmp-session-bus.patch (renamed from packages/dbus/dbus-glib-native-0.72/run-with-tmp-session-bus.patch)0
-rw-r--r--packages/dbus/dbus-glib-native_0.71.bb22
-rw-r--r--packages/dbus/dbus-glib-native_0.74.bb (renamed from packages/dbus/dbus-glib-native_0.72.bb)1
-rw-r--r--packages/dbus/dbus-glib/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-glib/cross.patch15
-rw-r--r--packages/dbus/dbus-glib/no-introspect.patch17
-rw-r--r--packages/dbus/dbus-glib_0.71.bb29
-rw-r--r--packages/dbus/dbus-glib_0.74.bb (renamed from packages/dbus/dbus-glib_0.72.bb)1
-rw-r--r--packages/dbus/dbus.inc18
-rw-r--r--packages/dbus/dbus/fix-segfault.patch11
-rw-r--r--packages/dbus/dbus_1.0.1.bb2
-rw-r--r--packages/dbus/dbus_1.0.2.bb13
18 files changed, 44 insertions, 132 deletions
diff --git a/packages/dbus/dbus-1.0.2/dbus-1.init b/packages/dbus/dbus-1.0.2/dbus-1.init
index 38e7574ad5..0725083c69 100644
--- a/packages/dbus/dbus-1.0.2/dbus-1.init
+++ b/packages/dbus/dbus-1.0.2/dbus-1.init
@@ -62,7 +62,8 @@ start_it_up()
shut_it_down()
{
if [ -d $EVENTDIR ]; then
- run-parts --reverse --arg=stop $EVENTDIR
+ # TODO: --reverse when busybox supports it
+ run-parts --arg=stop $EVENTDIR
fi
echo -n "Stopping $DESC: "
start-stop-daemon --stop --quiet --pidfile $PIDFILE \
@@ -75,6 +76,16 @@ shut_it_down()
rm -f $PIDFILE
}
+reload_it()
+{
+ echo -n "Reloading $DESC config: "
+ dbus-send --print-reply --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig > /dev/null
+ # hopefully this is enough time for dbus to reload it's config file.
+ echo "done."
+}
+
case "$1" in
start)
start_it_up
@@ -82,13 +93,16 @@ case "$1" in
stop)
shut_it_down
;;
- restart|force-reload)
+ reload|force-reload)
+ reload_it
+ ;;
+ restart)
shut_it_down
sleep 1
start_it_up
;;
*)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
exit 1
;;
esac
diff --git a/packages/dbus/dbus-glib-0.72/cross.patch b/packages/dbus/dbus-glib-0.72/cross.patch
deleted file mode 100644
index b3f41c8507..0000000000
--- a/packages/dbus/dbus-glib-0.72/cross.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: dbus-glib-0.72/configure.ac
-===================================================================
---- dbus-glib-0.72.orig/configure.ac 2006-10-27 10:05:05.000000000 +0200
-+++ dbus-glib-0.72/configure.ac 2006-10-27 10:05:48.000000000 +0200
-@@ -571,6 +571,7 @@
- exit (0);
- ]])],
- [have_abstract_sockets=yes],
-+ [have_abstract_sockets=no],
- [have_abstract_sockets=no])
- AC_LANG_POP(C)
- AC_MSG_RESULT($have_abstract_sockets)
diff --git a/packages/dbus/dbus-glib-0.72/.mtn2git_empty b/packages/dbus/dbus-glib-0.74/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/dbus/dbus-glib-0.72/.mtn2git_empty
+++ b/packages/dbus/dbus-glib-0.74/.mtn2git_empty
diff --git a/packages/dbus/dbus-glib/no-examples.patch b/packages/dbus/dbus-glib-0.74/no-examples.patch
index 483153db74..483153db74 100644
--- a/packages/dbus/dbus-glib/no-examples.patch
+++ b/packages/dbus/dbus-glib-0.74/no-examples.patch
diff --git a/packages/dbus/dbus-glib-0.72/no-introspect.patch b/packages/dbus/dbus-glib-0.74/no-introspect.patch
index 607f0acc9c..9115801f71 100644
--- a/packages/dbus/dbus-glib-0.72/no-introspect.patch
+++ b/packages/dbus/dbus-glib-0.74/no-introspect.patch
@@ -1,8 +1,8 @@
-Index: dbus-glib-0.72/tools/Makefile.am
+Index: dbus-glib-0.73/tools/Makefile.am
===================================================================
---- dbus-glib-0.72.orig/tools/Makefile.am 2006-10-25 21:10:36.000000000 +0200
-+++ dbus-glib-0.72/tools/Makefile.am 2006-10-27 10:07:35.000000000 +0200
-@@ -3,14 +3,8 @@
+--- dbus-glib-0.73.orig/tools/Makefile.am 2006-10-25 21:10:36.000000000 +0200
++++ dbus-glib-0.73/tools/Makefile.am 2006-10-27 10:07:35.000000000 +0200
+@@ -3,9 +3,6 @@
nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
libdbus_glibdir = $(includedir)/dbus-1.0/dbus
@@ -11,9 +11,4 @@ Index: dbus-glib-0.72/tools/Makefile.am
-
BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
--dbus-bus-introspect.xml:
-- DBUS_TOP_BUILDDIR=$(top_builddir) dbus-daemon --introspect > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
--
- EXTRA_DIST = run-with-tmp-session-bus.sh session.conf
-
- CLEANFILES = \
+ if USE_INTROSPECT_XML
diff --git a/packages/dbus/dbus-glib-native-0.72/.mtn2git_empty b/packages/dbus/dbus-glib-native-0.74/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/dbus/dbus-glib-native-0.72/.mtn2git_empty
+++ b/packages/dbus/dbus-glib-native-0.74/.mtn2git_empty
diff --git a/packages/dbus/dbus-glib-native-0.72/run-with-tmp-session-bus.patch b/packages/dbus/dbus-glib-native-0.74/run-with-tmp-session-bus.patch
index ba117d0309..ba117d0309 100644
--- a/packages/dbus/dbus-glib-native-0.72/run-with-tmp-session-bus.patch
+++ b/packages/dbus/dbus-glib-native-0.74/run-with-tmp-session-bus.patch
diff --git a/packages/dbus/dbus-glib-native_0.71.bb b/packages/dbus/dbus-glib-native_0.71.bb
deleted file mode 100644
index 1f5d71da91..0000000000
--- a/packages/dbus/dbus-glib-native_0.71.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SECTION = "base"
-PR = "r0"
-HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
-DESCRIPTION = "message bus system for applications to talk to one another"
-LICENSE = "GPL"
-
-SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-glib-${PV}.tar.gz \
- file://cross.patch;patch=1 \
- file://run-with-tmp-session-bus.patch;patch=1"
-
-inherit autotools pkgconfig gettext native
-
-S = "${WORKDIR}/dbus-glib-${PV}"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-glib"
-DEPENDS = "glib-2.0-native dbus-native"
-
-do_stage() {
- oe_runmake install
- install -d ${STAGING_DATADIR}/dbus
- install -m 0644 tools/dbus-bus-introspect.xml ${STAGING_DATADIR}/dbus
- install -m 0644 tools/dbus-glib-bindings.h ${STAGING_DATADIR}/dbus
-}
diff --git a/packages/dbus/dbus-glib-native_0.72.bb b/packages/dbus/dbus-glib-native_0.74.bb
index 842ddeb159..d76cc043d4 100644
--- a/packages/dbus/dbus-glib-native_0.72.bb
+++ b/packages/dbus/dbus-glib-native_0.74.bb
@@ -5,7 +5,6 @@ DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
- file://cross.patch;patch=1 \
file://run-with-tmp-session-bus.patch;patch=1"
inherit autotools pkgconfig gettext native
diff --git a/packages/dbus/dbus-glib/.mtn2git_empty b/packages/dbus/dbus-glib/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/dbus/dbus-glib/.mtn2git_empty
+++ /dev/null
diff --git a/packages/dbus/dbus-glib/cross.patch b/packages/dbus/dbus-glib/cross.patch
deleted file mode 100644
index 6d1d9d8e7e..0000000000
--- a/packages/dbus/dbus-glib/cross.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- dbus-0.20/configure.in~cross
-+++ dbus-0.20/configure.in
-@@ -466,6 +466,7 @@
- exit (0);
- ]])],
- [have_abstract_sockets=yes],
-+ [have_abstract_sockets=no],
- [have_abstract_sockets=no])
- AC_LANG_POP(C)
- AC_MSG_RESULT($have_abstract_sockets)
diff --git a/packages/dbus/dbus-glib/no-introspect.patch b/packages/dbus/dbus-glib/no-introspect.patch
deleted file mode 100644
index 7057a63020..0000000000
--- a/packages/dbus/dbus-glib/no-introspect.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- dbus-glib-0.70/tools/Makefile.am.orig 2006-07-23 15:53:06.000000000 +0200
-+++ dbus-glib-0.70/tools/Makefile.am 2006-07-23 15:53:53.000000000 +0200
-@@ -3,14 +3,8 @@
- nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
- libdbus_glibdir = $(includedir)/dbus-1.0/dbus
-
--dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/dbus/dbus-binding-tool$(EXEEXT)
-- $(top_builddir)/dbus/dbus-binding-tool --mode=glib-client --output=dbus-glib-bindings.h dbus-bus-introspect.xml
--
- BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
-
--dbus-bus-introspect.xml:
-- DBUS_TOP_BUILDDIR=$(top_builddir) dbus-send --system --print-reply=literal --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.Introspectable.Introspect > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
--
- EXTRA_DIST = run-with-tmp-session-bus.sh
-
- CLEANFILES = \
diff --git a/packages/dbus/dbus-glib_0.71.bb b/packages/dbus/dbus-glib_0.71.bb
deleted file mode 100644
index 26bc851098..0000000000
--- a/packages/dbus/dbus-glib_0.71.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SECTION = "base"
-PR = "r0"
-HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
-DESCRIPTION = "message bus system for applications to talk to one another"
-LICENSE = "GPL"
-DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
-
-SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-glib-${PV}.tar.gz \
- file://cross.patch;patch=1 \
- file://no-examples.patch;patch=1 \
- file://no-introspect.patch;patch=1"
-
-inherit autotools pkgconfig gettext
-
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
-
-do_configure_prepend() {
- install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-bus-introspect.xml ${S}/tools/
- install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-glib-bindings.h ${S}/tools/
-}
-
-do_stage () {
- oe_libinstall -so -C dbus libdbus-glib-1 ${STAGING_LIBDIR}
-
- autotools_stage_includes
-}
-
-FILES_${PN}-dev += "${bindir}/dbus-binding-tool"
diff --git a/packages/dbus/dbus-glib_0.72.bb b/packages/dbus/dbus-glib_0.74.bb
index 641f0263a2..3754abb708 100644
--- a/packages/dbus/dbus-glib_0.72.bb
+++ b/packages/dbus/dbus-glib_0.74.bb
@@ -6,7 +6,6 @@ LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
- file://cross.patch;patch=1 \
file://no-examples.patch;patch=1 \
file://no-introspect.patch;patch=1"
diff --git a/packages/dbus/dbus.inc b/packages/dbus/dbus.inc
index 8baf8d9feb..93eac00ccd 100644
--- a/packages/dbus/dbus.inc
+++ b/packages/dbus/dbus.inc
@@ -2,14 +2,15 @@ SECTION = "base"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
-DEPENDS = "expat virtual/libintl"
+DEPENDS = "expat glib-2.0 virtual/libintl"
-SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
file://tmpdir.patch;patch=1 \
file://dbus-1.init \
- file://fix-segfault.patch;patch=1 \
- file://cross.patch;patch=1 \
- file://fix-install-daemon.patch;patch=1"
+ "
inherit autotools pkgconfig update-rc.d gettext
@@ -18,8 +19,8 @@ INITSCRIPT_PARAMS = "defaults"
CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
-FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
+FILES_${PN} = "${bindir}/dbus-daemon* ${bindir}/dbus-uuidgen ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
pkg_postinst_dbus() {
#!/bin/sh
@@ -37,10 +38,11 @@ chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
}
-EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
--disable-checks --disable-xml-docs --disable-doxygen-docs \
--with-xml=expat --without-x"
+
do_stage () {
oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
diff --git a/packages/dbus/dbus/fix-segfault.patch b/packages/dbus/dbus/fix-segfault.patch
deleted file mode 100644
index de5bcff774..0000000000
--- a/packages/dbus/dbus/fix-segfault.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- /tmp/dbus-marshal-recursive.c 2006-07-28 14:58:08.000000000 +0200
-+++ dbus-0.90/dbus/dbus-marshal-recursive.c 2006-07-28 14:58:18.724411000 +0200
-@@ -1294,7 +1294,7 @@
- _dbus_string_get_length (&block->replacement) - block->padding,
- &fixups))
- goto oom;
--
-+printf("%s(%d)""got here", __FILE__, __LINE__);
- #if RECURSIVE_MARSHAL_WRITE_TRACE
- _dbus_verbose ("REPLACEMENT at padding %d len %d\n", block->padding,
- _dbus_string_get_length (&block->replacement) - block->padding);
diff --git a/packages/dbus/dbus_1.0.1.bb b/packages/dbus/dbus_1.0.1.bb
index 3c45ee8bd6..f5e4aa16ea 100644
--- a/packages/dbus/dbus_1.0.1.bb
+++ b/packages/dbus/dbus_1.0.1.bb
@@ -2,4 +2,4 @@ require dbus.inc
SRC_URI += "file://dbus-exploit-fix.patch;patch=1"
-PR = "r3"
+PR = "r4"
diff --git a/packages/dbus/dbus_1.0.2.bb b/packages/dbus/dbus_1.0.2.bb
index a660eb1586..c2b31db782 100644
--- a/packages/dbus/dbus_1.0.2.bb
+++ b/packages/dbus/dbus_1.0.2.bb
@@ -1,5 +1,14 @@
require dbus.inc
-SRC_URI += " file://fix-waitpid.patch;patch=1"
+DEFAULT_PREFERENCE = "1"
+
+PR = "r7"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://tmpdir.patch;patch=1 \
+ file://dbus-1.init \
+ file://cross.patch;patch=1 \
+ file://fix-install-daemon.patch;patch=1"
+
+
-PR = "r2"