summaryrefslogtreecommitdiff
path: root/packages/cron
diff options
context:
space:
mode:
Diffstat (limited to 'packages/cron')
-rw-r--r--packages/cron/cron_3.0pl1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/cron/cron_3.0pl1.bb b/packages/cron/cron_3.0pl1.bb
index e69de29bb2..bca3f89180 100644
--- a/packages/cron/cron_3.0pl1.bb
+++ b/packages/cron/cron_3.0pl1.bb
@@ -0,0 +1,15 @@
+SECTION = "base"
+DESCRIPTION = "Vixie cron."
+LICENSE = "cron"
+
+SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/cron${PV}.tar.gz \
+ file://nonrootinstall.patch;patch=1 \
+ file://time.patch;patch=1"
+S = "${WORKDIR}/cron${PV}"
+
+CFLAGS_append = " -I${S} -DSYS_TIME_H=0"
+do_install () {
+ install -d ${D}${sbindir} ${D}${bindir}
+ oe_runmake 'DESTDIR=${D}' install
+ chmod ugo+rx ${D}${sbindir}/* ${D}${bindir}/*
+}