summaryrefslogtreecommitdiff
path: root/packages/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'packages/busybox')
-rw-r--r--packages/busybox/busybox-1.13.2/get_header_tar.patch11
-rw-r--r--packages/busybox/busybox_1.13.2.bb6
2 files changed, 16 insertions, 1 deletions
diff --git a/packages/busybox/busybox-1.13.2/get_header_tar.patch b/packages/busybox/busybox-1.13.2/get_header_tar.patch
new file mode 100644
index 0000000000..0121cd1b61
--- /dev/null
+++ b/packages/busybox/busybox-1.13.2/get_header_tar.patch
@@ -0,0 +1,11 @@
+--- busybox-1.13.2/archival/libunarchive/get_header_tar.c.orig 2008-11-09 18:28:02.000000000 +0100
++++ busybox-1.13.2/archival/libunarchive/get_header_tar.c 2009-02-11 22:34:52.000000000 +0100
+@@ -252,6 +252,8 @@
+ file_header->name = concat_path_file(tar.prefix, tar.name);
+ } else
+ file_header->name = xstrdup(tar.name);
++ if (strlen(file_header->name) > 100)
++ file_header->name[100] = 0;
+ }
+
+ /* Set bits 12-15 of the files mode */
diff --git a/packages/busybox/busybox_1.13.2.bb b/packages/busybox/busybox_1.13.2.bb
index 5ae76b900d..f00830badb 100644
--- a/packages/busybox/busybox_1.13.2.bb
+++ b/packages/busybox/busybox_1.13.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r12"
+PR = "r13"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
@@ -12,6 +12,7 @@ SRC_URI = "\
file://udhcpscript.patch;patch=1 \
file://udhcpc-fix-nfsroot.patch;patch=1 \
file://B921600.patch;patch=1 \
+ file://get_header_tar.patch;patch=1 \
file://find-touchscreen.sh \
file://busybox-cron \
file://busybox-httpd \
@@ -31,6 +32,9 @@ EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
do_configure () {
install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ if [ "${TARGET_ARCH}" = "avr32" ] ; then
+ sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${S}/.config
+ fi
cml1_do_configure
}