summaryrefslogtreecommitdiff
path: root/packages/busybox/busybox_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/busybox/busybox_1.2.1.bb')
-rw-r--r--packages/busybox/busybox_1.2.1.bb32
1 files changed, 8 insertions, 24 deletions
diff --git a/packages/busybox/busybox_1.2.1.bb b/packages/busybox/busybox_1.2.1.bb
index 2c3d5c4cb7..2c004f5167 100644
--- a/packages/busybox/busybox_1.2.1.bb
+++ b/packages/busybox/busybox_1.2.1.bb
@@ -10,14 +10,13 @@ HOMEPAGE = "http://www.busybox.net"
LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
-PR = "r1.6"
+PR = "r1.7"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://dhcp-hostname.patch;patch=1 \
file://ifupdown-spurious-environ.patch;patch=1 \
file://udhcpscript.patch;patch=1 \
file://wget-long-options.patch;patch=1 \
- file://mdevdelnodes.patch;patch=1 \
file://defconfig \
file://busybox-cron \
file://busybox-httpd \
@@ -27,35 +26,29 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://default.script \
file://syslog.conf \
file://mount.busybox \
- file://umount.busybox \
- file://busybox-mdev.sh \
- file://mdev.conf \
- "
+ file://umount.busybox"
SRC_URI_append_nylon = " file://xargs-double-size.patch;patch=1"
export EXTRA_CFLAGS = "${CFLAGS}"
EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
-PACKAGES =+ "${PN}-httpd ${PN}-udhcpd ${PN}-mdev"
+PACKAGES =+ "${PN}-httpd ${PN}-udhcpd"
FILES_${PN}-httpd = "${sysconfdir}/init.d/busybox-httpd /srv/www"
FILES_${PN}-udhcpd = "${sysconfdir}/init.d/busybox-udhcpd"
-FILES_${PN}-mdev = "${sysconfdir}/init.d/busybox-mdev.sh ${sysconfdir}/mdev.conf"
FILES_${PN} += " ${datadir}/udhcpc"
-INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd ${PN}-udhcpd ${PN}-mdev"
+INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd ${PN}-udhcpd"
INITSCRIPT_NAME_${PN}-httpd = "busybox-httpd"
INITSCRIPT_NAME_${PN}-udhcpd = "busybox-udhcpd"
-INITSCRIPT_NAME_${PN}-mdev = "busybox-mdev.sh"
-INITSCRIPT_PARAMS_${PN}-mdev = "start 04 S ."
INITSCRIPT_NAME_${PN} = "syslog"
CONFFILES_${PN} = "${sysconfdir}/syslog.conf"
-inherit cml1 update-rc.d
-
# This disables the syslog startup links in openslug (see openslug-init)
-# INITSCRIPT_PARAMS_${PN}_openslug = "start 20 ." #out-of-date?
+INITSCRIPT_PARAMS_${PN}_openslug = "start 20 ."
+
+inherit cml1 update-rc.d
do_configure () {
install -m 0644 ${WORKDIR}/defconfig ${S}/.config.oe
@@ -122,7 +115,7 @@ do_install () {
install -m 0755 ${WORKDIR}/hwclock.sh ${D}${sysconfdir}/init.d/
fi
if grep "CONFIG_APP_UDHCPC=y" ${WORKDIR}/defconfig; then
- # Move dhcpc back to /sbin/udhcpc
+ # Move dhcpc back to /usr/sbin/udhcpc
install -d ${D}${base_sbindir}
mv ${D}/busybox${base_sbindir}/udhcpc ${D}${base_sbindir}/
@@ -132,15 +125,6 @@ do_install () {
install -m 0755 ${WORKDIR}/default.script ${D}${datadir}/udhcpc/default.script
fi
- if grep "CONFIG_MDEV=y" ${WORKDIR}/defconfig; then
- # Move mdev back to /sbin/mdev
- install -d ${D}${base_sbindir}
- mv ${D}/busybox${base_sbindir}/mdev ${D}${base_sbindir}/
-
- install -m 644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
- install -m 0755 ${WORKDIR}/busybox-mdev.sh ${D}${sysconfdir}/init.d/
- fi
-
install -m 0644 ${S}/busybox.links ${D}${sysconfdir}
}