summaryrefslogtreecommitdiff
path: root/recipes/ti/ti-xdctools-native_3.15.01.59.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-08-26 11:35:14 +0200
committerKoen Kooi <koen@openembedded.org>2009-08-26 11:35:14 +0200
commit172cb63ce5e91d489993590ec09e418aba019b4e (patch)
treee10d322895620ec0c96c2ab0efcd296bfc93b6b9 /recipes/ti/ti-xdctools-native_3.15.01.59.bb
parentbac5eef9c8a73672ee114926011addabb36610eb (diff)
dvsdk: rename to ti now that other things like bitblit live in that dir now
Diffstat (limited to 'recipes/ti/ti-xdctools-native_3.15.01.59.bb')
-rw-r--r--recipes/ti/ti-xdctools-native_3.15.01.59.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/ti/ti-xdctools-native_3.15.01.59.bb b/recipes/ti/ti-xdctools-native_3.15.01.59.bb
new file mode 100644
index 0000000000..d06cb8f615
--- /dev/null
+++ b/recipes/ti/ti-xdctools-native_3.15.01.59.bb
@@ -0,0 +1,22 @@
+inherit native
+require ti-xdctools.inc
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/rtsc/xdctools_3_15//exports/xdctools_setuplinux_3_15_01_59.bin"
+BINFILE = "xdctools_setuplinux_3_15_01_59.bin"
+
+S = "${WORKDIR}/xdctools_3_15_01_59"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "315"
+PR = "r4"
+
+do_stage() {
+ install -d -m 0755 ${STAGING_DIR_NATIVE}/${PN}
+ cp -pPrf ${S}/* ${STAGING_DIR_NATIVE}/${PN}
+ chmod 755 -R ${STAGING_DIR_NATIVE}/${PN}
+ # rm_work fails if you don't chmod S:
+ chmod 755 -R ${S}
+}
+
+AUTOTOOLS_NATIVE_STAGE_INSTALL = "1"
+