summaryrefslogtreecommitdiff
path: root/recipes/php/php_5.2.11.bb
diff options
context:
space:
mode:
authorGraeme Gregory <gg@slimlogic.co.uk>2009-12-10 13:08:58 -0700
committerGraeme Gregory <dp@xora.org.uk>2009-12-10 20:12:18 +0000
commitfa1e6ccdb109cade94bd87777d1fff372755c7da (patch)
tree394b6c2dd07e72f20cdbb2a8f642180e43b611d6 /recipes/php/php_5.2.11.bb
parent1994ec5fd25fc237ef42aadefd0fe719af20ef74 (diff)
php_5.2.11.bb : enable the imap extension, which also needed some openssl
I have patched up the autoconf stuff as it was searching in pretty hard coded paths for c-client and openssl.
Diffstat (limited to 'recipes/php/php_5.2.11.bb')
-rw-r--r--recipes/php/php_5.2.11.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes/php/php_5.2.11.bb b/recipes/php/php_5.2.11.bb
index d4fd98597a..058f1c2554 100644
--- a/recipes/php/php_5.2.11.bb
+++ b/recipes/php/php_5.2.11.bb
@@ -1,10 +1,12 @@
require php.inc
-DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
+DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql \
+ libc-client openssl"
-PR = "r1"
+PR = "r2"
SRC_URI += "file://pear-makefile.patch;patch=1 \
+ file://imap-fix-autofoo.patch;patch=1 \
"
export THREADS="pthread"
export LIBS=" -lpthread "
@@ -20,6 +22,8 @@ EXTRA_OECONF = " --without-iconv \
--enable-embedded-mysqli \
--enable-magic-quotes \
--enable-fastcgi \
+ --with-imap=${STAGING_DIR_HOST} \
+ --with-imap-ssl=${STAGING_DIR_HOST} \
--with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
--with-libxml-dir=${STAGING_BINDIR_CROSS} \
--with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \