summaryrefslogtreecommitdiff
path: root/recipes/pf_ring/libpfring_svn.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-08-02 18:14:39 +0400
committerRoman I Khimov <khimov@altell.ru>2010-08-05 09:36:47 +0400
commit5e02e8de46439e09aa527813f335b785cd389ecf (patch)
treebb3124fa36812499d99f3a824bd5be2aa58b6d17 /recipes/pf_ring/libpfring_svn.bb
parentd3d01844cb2448c07b19b9b27754ec5d4d999825 (diff)
pf_ring: add recipes for PF_RING kernel module and userspace library
PF_RING is a new type of network socket that dramatically improves the packet capture speed. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/pf_ring/libpfring_svn.bb')
-rw-r--r--recipes/pf_ring/libpfring_svn.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/pf_ring/libpfring_svn.bb b/recipes/pf_ring/libpfring_svn.bb
new file mode 100644
index 0000000000..711d2893d1
--- /dev/null
+++ b/recipes/pf_ring/libpfring_svn.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "PF_RING is a new type of network socket that dramatically improves the packet capture speed, this package contains userspace library for interaction with kernel PF_RING module"
+SECTION = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.ntop.org/PF_RING.html"
+DEPENDS += "pf-ring"
+PV = "4.4.0+svnr${SRCPV}"
+
+S = "${WORKDIR}/lib"
+
+SRCREV = "4326"
+SRC_URI = " \
+ svn://svn.ntop.org/svn/ntop/trunk/PF_RING/userland;module=lib;proto=https \
+ file://libpfring-makefile-fixes.patch;patch=1;pnum=0 \
+ "
+
+CFLAGS += "-fPIC"
+LDFLAGS += "-shared"
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+RRECOMMENDS_${PN} = "pf-ring"