summaryrefslogtreecommitdiff
path: root/recipes/orinoco/spectrum-fw.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/orinoco/spectrum-fw.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/orinoco/spectrum-fw.bb')
-rw-r--r--recipes/orinoco/spectrum-fw.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/orinoco/spectrum-fw.bb b/recipes/orinoco/spectrum-fw.bb
new file mode 100644
index 0000000000..f2e11eea74
--- /dev/null
+++ b/recipes/orinoco/spectrum-fw.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Firmware for Spectrum Wireless LAN cards"
+DEPENDS += " unzip-native "
+LICENSE = "unknown"
+PR = "r1"
+
+SRC_URI = "file://get_symbol_fw \
+ file://parse_symbol_fw"
+S = "${WORKDIR}"
+
+do_configure() {
+ ./get_symbol_fw
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/firmware/
+ install -m 0755 ${WORKDIR}/symbol_sp24t_prim_fw ${D}${base_libdir}/firmware/symbol_sp24t_prim_fw
+ install -m 0755 ${WORKDIR}/symbol_sp24t_sec_fw ${D}${base_libdir}/firmware/symbol_sp24t_sec_fw
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += "${base_libdir}/firmware/symbol*"