summaryrefslogtreecommitdiff
path: root/recipes/mamona/mamonaim-e-applet_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mamona/mamonaim-e-applet_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mamona/mamonaim-e-applet_git.bb')
-rw-r--r--recipes/mamona/mamonaim-e-applet_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/mamona/mamonaim-e-applet_git.bb b/recipes/mamona/mamonaim-e-applet_git.bb
new file mode 100644
index 0000000000..6f45a457c4
--- /dev/null
+++ b/recipes/mamona/mamonaim-e-applet_git.bb
@@ -0,0 +1,36 @@
+# Copyright (C) 2008 Instituto Nokia de Tecnologia
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Mamona-IM Enlightenment Applet"
+HOMEPAGE = "http://dev.openbossa.org/trac/mamona/wiki"
+LICENSE = "MIT BSD"
+DEPENDS = "mamona-input-methods e-wm"
+PR = "r0"
+
+PV = "0.1+git"
+
+inherit autotools pkgconfig
+
+SRC_URI = "git://dev.openbossa.org/mamona/projects/mamonaim_e_applet.git;protocol=http"
+
+S = "${WORKDIR}/git"
+
+# E Applet
+FILES_${PN} = "\
+ ${libdir}/enlightenment/modules/mamonaim/module.desktop \
+ ${libdir}/enlightenment/modules/mamonaim/mamonaim.edj \
+ ${libdir}/enlightenment/modules/mamonaim/e-module-mamonaim.edj \
+ ${libdir}/enlightenment/modules/mamonaim/*.png \
+ ${libdir}/enlightenment/modules/mamonaim/*/module.so \
+ "
+FILES_${PN}-dev = "\
+ ${libdir}/enlightenment/modules/mamonaim/*/module.la \
+ ${libdir}/enlightenment/modules/mamonaim/*/module.a \
+ "
+FILES_${PN}-dbg = "\
+ ${libdir}/enlightenment/modules/mamonaim/*/.debug \
+ "
+
+do_configure_prepend() {
+ ./autogen.sh
+}