summaryrefslogtreecommitdiff
path: root/recipes/libnl/libnl_1.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libnl/libnl_1.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libnl/libnl_1.1.bb')
-rw-r--r--recipes/libnl/libnl_1.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/libnl/libnl_1.1.bb b/recipes/libnl/libnl_1.1.bb
new file mode 100644
index 0000000000..dcca3c6e92
--- /dev/null
+++ b/recipes/libnl/libnl_1.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "libnl is a library for applications dealing with netlink sockets"
+SECTION = "libs/network"
+LICENSE = "LGPL"
+HOMEPAGE = "http://people.suug.ch/~tgr/libnl"
+PR = "r1"
+
+inherit autotools pkgconfig
+
+CFLAGS += '-DVLAN_FLAG_REORDER_HDR=1'
+
+SRC_URI = "\
+ http://people.suug.ch/~tgr/libnl/files/libnl-${PV}.tar.gz \
+ file://local-includes-and-avoid-wrong-ldflags.patch;patch=1 \
+ file://fix-includes.patch;patch=1 \
+"
+
+do_stage () {
+ autotools_stage_all prefix=${prefix}
+}