summaryrefslogtreecommitdiff
path: root/recipes/gnuradio/gnuradio_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-01 15:39:06 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-01 15:39:06 +0200
commit71e69ad8b551aa06f63160232d1bd87b8d801a1d (patch)
tree9aab0256970f53fd7a3266d1bd53d11d71950120 /recipes/gnuradio/gnuradio_svn.bb
parentc289210c5b3983dc78ff82a2ba8e80989d846211 (diff)
gnuradio: add hack to build a private copy of libusb (the gnarly old one) and statically link that since gnuradio is using private methods of libusb that libusb-compat won't provide
Diffstat (limited to 'recipes/gnuradio/gnuradio_svn.bb')
-rw-r--r--recipes/gnuradio/gnuradio_svn.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/recipes/gnuradio/gnuradio_svn.bb b/recipes/gnuradio/gnuradio_svn.bb
index 56db9187c4..73348bf208 100644
--- a/recipes/gnuradio/gnuradio_svn.bb
+++ b/recipes/gnuradio/gnuradio_svn.bb
@@ -5,14 +5,21 @@ DEFAULT_PREFERENCE = "-1"
DEPENDS += " gsl "
PV = "3.1.3+svnr${SRCREV}"
-PR = "r6"
+PR = "r7"
EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable-usrp1 --disable--usrp2"
SRC_URI = "svn://gnuradio.org/svn/gnuradio/;module=trunk;proto=http \
file://no-usrp2.patch;patch=1 \
file://gnuradio-neon.patch;patch=1;pnum=0 \
- "
+ ${SOURCEFORGE_MIRROR}/libusb/libusb-0.1.12.tar.gz \
+"
+
+# This is an awful hack to allow GNU Radio to use libusb-0.12, regardless
+# of what is used by the rest of OE
+
+addtask buildlibusb before do_configure after do_unpack
+
S="${WORKDIR}/trunk"