summaryrefslogtreecommitdiff
path: root/recipes/dvsdk/ti-codec-combo-dm355_1.13.bb
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2009-06-16 16:42:27 +0100
committerPhil Blundell <philb@gnu.org>2009-06-16 16:42:27 +0100
commit4e0f69867535f4a93e0af3ffb26336e1a3a85f65 (patch)
treec4e1f45e61cc101564036737ba3518de74c5ed01 /recipes/dvsdk/ti-codec-combo-dm355_1.13.bb
parent73bdf9cc0c931f8d49596bc89ceb632e2e464d84 (diff)
parente2b659db223fca8b5e3e8c3241da0d8a3399f25e (diff)
Merge branch 'org.openembedded.dev' of git@new.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/dvsdk/ti-codec-combo-dm355_1.13.bb')
-rw-r--r--recipes/dvsdk/ti-codec-combo-dm355_1.13.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/dvsdk/ti-codec-combo-dm355_1.13.bb b/recipes/dvsdk/ti-codec-combo-dm355_1.13.bb
new file mode 100644
index 0000000000..3827a1f7e1
--- /dev/null
+++ b/recipes/dvsdk/ti-codec-combo-dm355_1.13.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "DM355 Codec Combo 1.13"
+
+require ti-codec-combo-dm355.inc
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/dvsdk/codecs/dm355_codecs_setuplinux_1_13_000.bin \
+ file://mapdmaq \
+ "
+
+S = "${WORKDIR}/dm355_codecs_1_13_000"
+BINFILE="dm355_codecs_setuplinux_1_13_000.bin"
+installdir = "${prefix}/ti"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "113"
+PR = "r12"
+
+do_compile() {
+ echo "Do nothing"
+}
+
+do_install () {
+ # install mapdmaq on target
+ install -d ${D}/${installdir}/codec-combo
+ install -m 0755 ${WORKDIR}/mapdmaq ${D}/${installdir}/codec-combo
+}
+
+do_stage() {
+ install -d ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/${PN}
+ cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/${PN}/
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+INHIBIT_PACKAGE_STRIP = "1"
+INSANE_SKIP_${PN} = True
+FILES_${PN} = "${installdir}/codec-combo/mapdmaq"
+