summaryrefslogtreecommitdiff
path: root/packages/xorg-lib/libxt_0.1.5.bb
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-07-24 19:46:41 +0000
committerRaymond Danks <raymond@edanks.com>2006-07-24 19:46:41 +0000
commitdd0c887b669ed5f2fdfa21118f4b32d096e92816 (patch)
tree52a9bb766480ea9983a6e3e5d4ae600e0a482f2c /packages/xorg-lib/libxt_0.1.5.bb
parentb88c8ee5fdd3c5bda8a7fea778c3d7b09b180622 (diff)
xorg-*: Massive rename to conform to X11R7.x_a.b.c versioning and xorg-* directory structure.
This is the first step for the update to X11R7.1. This will not build and will be followed by more patches and updates.
Diffstat (limited to 'packages/xorg-lib/libxt_0.1.5.bb')
-rw-r--r--packages/xorg-lib/libxt_0.1.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/xorg-lib/libxt_0.1.5.bb b/packages/xorg-lib/libxt_0.1.5.bb
new file mode 100644
index 0000000000..00cbe9a3ad
--- /dev/null
+++ b/packages/xorg-lib/libxt_0.1.5.bb
@@ -0,0 +1,29 @@
+SECTION = "x11/libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "libx11 libsm"
+PROVIDES = "xt"
+DESCRIPTION = "X Toolkit Intrinsics"
+LICENSE = "X-MIT"
+PR = "r1"
+SRC_URI = "${XLIBS_MIRROR}/libXt-${PV}.tar.bz2 \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/libXt-${PV}"
+
+PARALLEL_MAKE = ""
+
+inherit autotools pkgconfig
+
+#nasty hack as utils need to be native
+do_compile() {
+ (
+ unset CC LD CXX CCLD
+# unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake -C util 'CFLAGS=' 'LDFLAGS=' 'CXXFLAGS=' 'CPPFLAGS=' makestrs
+ )
+ oe_runmake
+}
+
+do_stage () {
+ autotools_stage_all
+}