summaryrefslogtreecommitdiff
path: root/packages/xev
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-05 14:48:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-05 14:48:27 +0000
commitacea698b756c5c16784d5b446ea3366abd866e12 (patch)
treee92d9b9e4bc2d77d9acae7d0ade5c03906049712 /packages/xev
parent3801493a4c9a2f09bed30fad0b1209bd50f5c642 (diff)
xev: set PV so CVSDATE is included. fix misleading HOMEPAGE, incorrect LICENSE. adjust SECTION. remove bogus "inherit autotools" and hardcoded paths.
Diffstat (limited to 'packages/xev')
-rw-r--r--packages/xev/xev_cvs.bb18
1 files changed, 7 insertions, 11 deletions
diff --git a/packages/xev/xev_cvs.bb b/packages/xev/xev_cvs.bb
index 4d47df9e7a..7dccdaad3c 100644
--- a/packages/xev/xev_cvs.bb
+++ b/packages/xev/xev_cvs.bb
@@ -1,25 +1,21 @@
+PV = "0.0cvs${CVSDATE}"
DESCRIPTION = "X Event Viewer"
-HOMEPAGE = "http://www.xfree86.org/current/xev.1.html"
-LICENSE = "GPLv2"
+HOMEPAGE = "http://freedesktop.org/wiki/Software_2fxapps"
+LICENSE = "MIT"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
-SECTION = "x11/utils"
+SECTION = "x11/base"
DEPENDS = "x11 xau"
-PR = "r0"
+PR = "r1"
SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xapps;module=xev \
file://diet-x11.patch;patch=1"
S = "${WORKDIR}/xev"
-inherit autotools
-
do_compile() {
${CC} -o xev xev.c -lX11 -lXau -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
}
do_install() {
- install -d ${D}/usr/bin/
- install -m 755 ${PN} ${D}/usr/bin/${PN}
+ install -d ${D}${bindir}
+ install -m 755 ${PN} ${D}${bindir}
}
-
-FILES = "/usr/bin/xev"
-