summaryrefslogtreecommitdiff
path: root/packages/wwwoffle/wwwoffle_2.9c.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2008-05-23 15:59:49 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2008-05-23 15:59:49 +0000
commit33b90e2dbb1f21ba4511f3e85dfeab1ae24502c4 (patch)
tree04b505d6d032b8fb91eb9772a57fb0c5e5f393e8 /packages/wwwoffle/wwwoffle_2.9c.bb
parentef71e5fbb312339650882401b54739a5e60726fc (diff)
parentdf42d84d1ac1fc35e56fa66cf6559ce6ca2893d3 (diff)
merge of '5135d5b0b85d509b8af80d221f18563d4ce62475'
and '8b21a69e52feb768f1d096aa78e44dd20ce3aed4'
Diffstat (limited to 'packages/wwwoffle/wwwoffle_2.9c.bb')
-rw-r--r--packages/wwwoffle/wwwoffle_2.9c.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/wwwoffle/wwwoffle_2.9c.bb b/packages/wwwoffle/wwwoffle_2.9c.bb
new file mode 100644
index 0000000000..c280e7c8a9
--- /dev/null
+++ b/packages/wwwoffle/wwwoffle_2.9c.bb
@@ -0,0 +1,31 @@
+LICENSE = "GPL"
+SECTION = "console/network"
+PRIORITY = "standard"
+DESCRIPTION = "World Wide Web Offline Explorer"
+DEPENDS = ""
+
+SRC_URI = "http://www.gedanken.demon.co.uk/download-wwwoffle/${PN}-${PV}.tgz \
+ file://wwwoffle.init \
+ file://wwwoffle.if-up \
+ file://wwwoffle.if-down"
+
+INITSCRIPT_NAME = "${PN}"
+
+inherit autotools gettext update-rc.d
+
+EXTRA_OEMAKE = "docdir=${datadir}/doc"
+
+do_configure() {
+ pwd
+ mv aclocal.m4 acinclude.m4
+ autotools_do_configure
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/network/if-up.d
+ install -m 755 ${WORKDIR}/wwwoffle.if-up ${D}/${sysconfdir}/network/if-up.d/wwwoffle
+ install -d ${D}/${sysconfdir}/network/if-down.d
+ install -m 755 ${WORKDIR}/wwwoffle.if-down ${D}/${sysconfdir}/network/if-down.d/wwwoffle
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/wwwoffle.init ${D}/${sysconfdir}/init.d/wwwoffle
+}