summaryrefslogtreecommitdiff
path: root/packages/wifistix/wifistix-modules_5.0.16.p0.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-18 16:35:01 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-18 16:35:01 +0000
commit2b94d96062ac7eb6a15445f74e424b7b08e69a63 (patch)
treea4ceb58e4985908f2dd574d498e1e17f38061f5e /packages/wifistix/wifistix-modules_5.0.16.p0.bb
parent51d88fa521229df09a9d624618d7e861d765d21a (diff)
parent0ed630ee92d26828b61f1de72dc0b33d2a056123 (diff)
merge of '1d0e13e8c6528e7a7037276e3c01cb21dfa085e4'
and '86581f7de9bc72fe5e21778b4442cc0e59e96fbf'
Diffstat (limited to 'packages/wifistix/wifistix-modules_5.0.16.p0.bb')
-rw-r--r--packages/wifistix/wifistix-modules_5.0.16.p0.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/packages/wifistix/wifistix-modules_5.0.16.p0.bb b/packages/wifistix/wifistix-modules_5.0.16.p0.bb
new file mode 100644
index 0000000000..923f24e27a
--- /dev/null
+++ b/packages/wifistix/wifistix-modules_5.0.16.p0.bb
@@ -0,0 +1,50 @@
+DESCRIPTION = "Linux Driver for Marvel 88W8385 802.11b/g Wifi Module used in Gumstix daughtercards"
+SECTION = "base"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.gumstix.com"
+LICENSE = "GPL"
+RDEPENDS = "kernel (${KERNEL_VERSION})"
+DEPENDS = "virtual/kernel"
+PR = "r0"
+
+SRC_URI = "http://files.gumstix.com/cf8385-5.0.16.p0-26306.tbz \
+ file://wifistix.conf \
+ file://marvell-devicename.patch;patch=1 \
+ file://marvell-devicetable.patch;patch=1 \
+ file://marvell-gumstix.patch;patch=1 \
+ file://sbi-no-inline.patch;patch=1 \
+ file://2.6.17-new-pcmcia-layer.patch;patch=1 \
+ file://bad-cast.patch;patch=1 \
+ file://struct-changes.patch;patch=1 \
+ file://no-more-config-h.patch;patch=1 \
+ file://realtime-kernel.patch;patch=1 \
+ file://install-properly.patch;patch=1 \
+ file://fix-essid-truncation.patch;patch=1"
+
+S = "${WORKDIR}/src_cf8385"
+
+inherit module-base
+
+EXTRA_OEMAKE = 'CONFIG_GUMSTIX=y CONFIG_DEBUG=n KVER=2.6 \
+ KERNELDIR="${KERNEL_SOURCE}" ARCH="${TARGET_ARCH}" \
+ CC="${KERNEL_CC}" EXTRA_CFLAGS="${CFLAGS}" \
+ INSTALL_MOD_PATH="${D}"'
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake
+}
+
+do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake install
+
+ install -m 0755 -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 ${WORKDIR}/wifistix.conf ${D}${sysconfdir}/modprobe.d/wifistix.conf
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "${base_libdir}/modules/"
+FILES_${PN} += "${sysconfdir}/modprobe.d/"
+CONFFILES_${PN} = "${sysconfdir}/modprobe.d/wifistix.conf"
+