summaryrefslogtreecommitdiff
path: root/packages/squeak/squeak-nox_3.4-2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/squeak/squeak-nox_3.4-2.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/squeak/squeak-nox_3.4-2.bb')
-rw-r--r--packages/squeak/squeak-nox_3.4-2.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/squeak/squeak-nox_3.4-2.bb b/packages/squeak/squeak-nox_3.4-2.bb
index e69de29bb2..02c3520c09 100644
--- a/packages/squeak/squeak-nox_3.4-2.bb
+++ b/packages/squeak/squeak-nox_3.4-2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Squeak VM for QtEmbedded"
+SECTION = "devel"
+PRIORITY = "optional"
+MAINTAINER = "Torsten Sadowski <tsadowski@gmx.net>"
+LICENSE = "Squeak License"
+HOMEPAGE = "http://www.squeak.org"
+DEPENDS = "virtual/libqpe"
+PROVIDES = "virtual/squeak-nox"
+PR = "r1"
+
+SRC_URI = "http://keepcool.kf.tu-berlin.de/public/mitarbeiter/sadowski/qtopia-squeak-${PV}_patched.tar.gz \
+ file://Makefile.in"
+S = "${WORKDIR}"
+
+EXTRA_OECONF = ' --host=arm-linux --without-x --without-npsqueak --with-audio=oss'
+
+inherit palmtop
+
+do_configure() {
+ cp platforms/unix/vm/aio.h platforms/unix/vm/sqaio.h
+ cp ${WORKDIR}/Makefile.in platforms/unix/vm/Makefile.in
+ rm -rf build
+ mkdir build
+ cd build
+ ../platforms/unix/config/configure ${EXTRA_OECONF}
+}
+
+do_compile() {
+ cd build
+ make
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/
+ install -m 0755 ${WORKDIR}/build/squeak-nox ${D}${palmtopdir}/bin/
+ install -d ${D}/${palmtopdir}/apps/Applications/
+ install -m 0644 squeak.desktop ${D}/${palmtopdir}/apps/Applications/squeak.desktop
+ install -d ${D}/${palmtopdir}/pics/
+ install -m 0644 SqueakLogo.png ${D}/${palmtopdir}/pics/SqueakLogo.png
+ install -d ${D}/${palmtopdir}/share/apps/squeak/
+ install -m 0644 README ${D}/${palmtopdir}/share/apps/squeak/
+}