summaryrefslogtreecommitdiff
path: root/packages/scummvm/scummvm_0.6.0.bb
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2009-01-22 15:55:12 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2009-01-22 19:06:21 +0100
commitfbe9f3dae3a57556e20d76b4fb76cd14e2f83b61 (patch)
tree1e1149f8d46b7c8b5e1e2d924838e664128cf986 /packages/scummvm/scummvm_0.6.0.bb
parente9c568554b7c6a8fd091cbd2453dbf29dd35bd29 (diff)
scummvm: fix the fact that none of the engines were builtin(so scummvm was useless) while keeping ENTERPRISE_DISTRO and minor fixes:
*took the lacking scummvm/files/openmoko/openmoko-scummvm from the openmoko wiki *no-strip.patch for the 0.12.0 version : if you let the Makefile strip,openembedded skip stripping and so it can't copy the unstripped binaries before stripping...and so it creates an empty -dbg package *must check the stripping for the others versions *explanation of the main fix: most of the recipes added something like this: DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '-DUSE_MAD -DUSE_MPEG2', d)}" this did override the DEFINES...and so defines such as -DENABLE_ENGINENAME=STATIC_PLUGIN were no longer defined...and so none of the engines were built... I removed it and remplaced it by ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mpeg2', '--with-mpeg2-prefix=${STAGING_LIBDIR}/..', d)} \ ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mad', '--with-mad-prefix=${STAGING_LIBDIR}/..', d)} \ I've also tested it with ENTREPRISE_DISTRO = "1" in my local.conf here are what I checked: **the configure log: Checking for MAD... no Checking for libmpeg2 >= 0.3.2... no **the run.do_configure.21902 shell script: --disable-mpeg2 twice in oe_runconf and in do_configure ..no other matches for mpeg same thing for --disable-mad **the about menu inside scummvm says vorbis zlib in the "features compiled in" section and there were no mention of mad,mp3 or mpeg2 *bump all PR
Diffstat (limited to 'packages/scummvm/scummvm_0.6.0.bb')
-rw-r--r--packages/scummvm/scummvm_0.6.0.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/packages/scummvm/scummvm_0.6.0.bb b/packages/scummvm/scummvm_0.6.0.bb
index 9c8477dcaa..6ff76e6eb2 100644
--- a/packages/scummvm/scummvm_0.6.0.bb
+++ b/packages/scummvm/scummvm_0.6.0.bb
@@ -9,6 +9,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/scummvm/scummvm-${PV}.tar.bz2 \
file://sword1.patch;patch=1 \
file://tremor.patch;patch=1 \
file://mouse.patch;patch=1 "
+PR="r1"
inherit autotools
@@ -19,18 +20,13 @@ EXTRA_OECONF = "--host=${HOST_SYS} \
--disable-alsa \
--with-ogg-prefix=${STAGING_LIBDIR}/.. \
--with-vorbis-prefix=${STAGING_LIBDIR}/.. \
- --with-mpeg2-prefix=${STAGING_LIBDIR}/.. \
- --with-mad-prefix=${STAGING_BINDIR_CROSS}/.. "
-
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mpeg2', '--with-mpeg2-prefix=${STAGING_LIBDIR}/..', d)} \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mad', '--with-mad-prefix=${STAGING_BINDIR_CROSS}/..', d)} \
+ "
do_configure() {
./configure ${EXTRA_OECONF}
}
-do_compile() {
- oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS} -lmpeg2" \
- DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DQTOPIA -DUSE_MAD -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2"
-}
-
do_install() {
install -d ${D}${bindir}
install -m 0755 scummvm ${D}${bindir}/scummvm