summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-03-23 10:53:46 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-03-23 10:53:46 +0000
commit9840a3458d188fc6c1e44ae7760d9007117dfbea (patch)
tree0a5d79e061ab95cedcee5504ed54d4d26dd75309 /packages/python
parenta64bb5d2b964bafe23d158dd455446ce5d5015ea (diff)
python-pygtk2: make it build on 64bit host for 32bit machine (from Poky)
Informations why it is needed sent to mailing list.
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-pygtk2/acinclude.m46
-rw-r--r--packages/python/python-pygtk2_2.10.3.bb1
-rw-r--r--packages/python/python-pygtk2_2.6.3.bb2
-rw-r--r--packages/python/python-pygtk2_2.8.6.bb6
4 files changed, 13 insertions, 2 deletions
diff --git a/packages/python/python-pygtk2/acinclude.m4 b/packages/python/python-pygtk2/acinclude.m4
index eec3758afc..53518fb2eb 100644
--- a/packages/python/python-pygtk2/acinclude.m4
+++ b/packages/python/python-pygtk2/acinclude.m4
@@ -43,12 +43,18 @@ AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
[AC_REQUIRE([AM_PATH_PYTHON])
AC_MSG_CHECKING(for headers required to compile python extensions)
dnl deduce PYTHON_INCLUDES
+AC_ARG_WITH(python-includes,
+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
+if test x$py_exec_prefix != x; then
+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+else
py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
if test "$py_prefix" != "$py_exec_prefix"; then
PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
fi
+fi
AC_SUBST(PYTHON_INCLUDES)
dnl check if the headers exist:
save_CPPFLAGS="$CPPFLAGS"
diff --git a/packages/python/python-pygtk2_2.10.3.bb b/packages/python/python-pygtk2_2.10.3.bb
index d040299a0e..f7366af401 100644
--- a/packages/python/python-pygtk2_2.10.3.bb
+++ b/packages/python/python-pygtk2_2.10.3.bb
@@ -13,6 +13,7 @@ SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.10/${SRCNAME}-${PV}.tar
S = "${WORKDIR}/${SRCNAME}-${PV}"
EXTRA_OECONF = "--disable-docs"
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
inherit autotools pkgconfig distutils-base
diff --git a/packages/python/python-pygtk2_2.6.3.bb b/packages/python/python-pygtk2_2.6.3.bb
index 61250631ef..ffd837f0da 100644
--- a/packages/python/python-pygtk2_2.6.3.bb
+++ b/packages/python/python-pygtk2_2.6.3.bb
@@ -13,6 +13,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit autotools pkgconfig distutils-base
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-doc ${PN}"
FILES_${PN}-dbg += "${libdir}/python2.4/site-packages/gtk-2.0/gtk/.debug \
${libdir}/python2.4/site-packages/gtk-2.0/.debug"
diff --git a/packages/python/python-pygtk2_2.8.6.bb b/packages/python/python-pygtk2_2.8.6.bb
index ab571bdfd9..b3d8c93584 100644
--- a/packages/python/python-pygtk2_2.8.6.bb
+++ b/packages/python/python-pygtk2_2.8.6.bb
@@ -1,11 +1,11 @@
DESCRIPTION = "Python GTK+ Bindings"
SECTION = "devel/python"
-# needs gtk+-2.8.x
+PRIORITY = "optional"
DEPENDS = "gtk+ libglade"
RDEPENDS = "python-shell"
SRCNAME = "pygtk"
LICENSE = "LGPL"
-PR = "ml0"
+PR = "r1"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.8/${SRCNAME}-${PV}.tar.bz2 \
file://acinclude.m4"
@@ -13,6 +13,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit autotools pkgconfig distutils-base
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
do_configure_prepend() {
install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
}