summaryrefslogtreecommitdiff
path: root/packages/python/python-pylinda
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-02-08 18:05:47 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-02-08 18:05:47 +0000
commit6579e8daf68dd520b702412208bfeae85af6fadc (patch)
treeef2cfbfe3353bd39e28145995db1287bd2518b8d /packages/python/python-pylinda
parentc6c085bf81bd4997bdb216e958d366ddf46438ad (diff)
make python 2.4 as default, move python-sip into python/, make sip4 as default
BKrev: 4208ff7b-sgl7QbT_1xhYPmdi-Oy4g
Diffstat (limited to 'packages/python/python-pylinda')
-rw-r--r--packages/python/python-pylinda/honor-datadir.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/python/python-pylinda/honor-datadir.patch b/packages/python/python-pylinda/honor-datadir.patch
index e69de29bb2..9035804592 100644
--- a/packages/python/python-pylinda/honor-datadir.patch
+++ b/packages/python/python-pylinda/honor-datadir.patch
@@ -0,0 +1,29 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linda-0.4/setup.py~honor-datadir.patch
++++ linda-0.4/setup.py
+@@ -74,7 +74,7 @@
+ class myinstall(install):
+ def run(self):
+ install.run(self)
+-
++ return
+ print "PyLinda's post-install options"
+
+ # the following is taken from the install_scripts standard command
+@@ -123,9 +123,9 @@
+ Topic :: System :: Distributed Computing""".split("\n"),
+ version="0.4",
+ scripts=["linda_server.py"],
+- data_files=[(root_path+"/examples", glob.glob("examples/*.py")),
+- (root_path+"/doc", glob.glob("doc/html/*")),
+- (root_path, ["README"])],
++ data_files=[("examples", glob.glob("examples/*.py")),
++ ("doc", glob.glob("doc/html/*")),
++ (".", ["README"])],
+ ext_modules=ext,
+ packages=["linda"],
+ package_dir={"linda": ""},