summaryrefslogtreecommitdiff
path: root/packages/python/python-dbus_0.83.0.bb
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2008-08-01 19:42:12 +0000
committerPhil Blundell <philb@gnu.org>2008-08-01 19:42:12 +0000
commitd91644f23743d5bb330ab64634b9f785982da377 (patch)
tree5aa8cc6a9043329b0413f8b7b3dc485c0a9fab1e /packages/python/python-dbus_0.83.0.bb
parent9f60719726356657d559aa1e045c9ae126f13e32 (diff)
parente2bf1be715145512644049402e4e94083c938445 (diff)
merge of 'a061abf4bdeedaccdb10ef3b7372827d261db509'
and 'c6e91bf295f3be4e74e18520fdbb8aeb20908d3e'
Diffstat (limited to 'packages/python/python-dbus_0.83.0.bb')
-rw-r--r--packages/python/python-dbus_0.83.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/python/python-dbus_0.83.0.bb b/packages/python/python-dbus_0.83.0.bb
new file mode 100644
index 0000000000..4ccecc0aa1
--- /dev/null
+++ b/packages/python/python-dbus_0.83.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+RDEPENDS = "python-io python-logging python-stringold python-threading python-xml"
+PR = "ml0"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+export BUILD_SYS := "${BUILD_SYS}"
+export HOST_SYS := "${HOST_SYS}"
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dev += "${libdir}/pkgconfig