summaryrefslogtreecommitdiff
path: root/packages/ppp-dsl
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/ppp-dsl
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/ppp-dsl')
-rw-r--r--packages/ppp-dsl/files/dsl-provider71
-rwxr-xr-xpackages/ppp-dsl/files/ppp_on_boot.dsl14
-rw-r--r--packages/ppp-dsl/ppp-dsl_0.1.bb30
3 files changed, 0 insertions, 115 deletions
diff --git a/packages/ppp-dsl/files/dsl-provider b/packages/ppp-dsl/files/dsl-provider
deleted file mode 100644
index 6feaf55752..0000000000
--- a/packages/ppp-dsl/files/dsl-provider
+++ /dev/null
@@ -1,71 +0,0 @@
-# Configuration file for PPP, using PPP over Ethernet
-# to connect to a DSL provider.
-#
-# See the manual page pppd(8) for information on all the options.
-
-##
-# Section 1
-#
-# Stuff to configure...
-
-# MUST CHANGE: Uncomment the following line, replacing the user@provider.net
-# by the DSL user name given to your by your DSL provider.
-# (There should be a matching entry in /etc/ppp/pap-secrets with the password.)
-#
-# maybe helpful for germany:
-# T-DSL business PAP "t-online-com/111111111111@t-online-com.de"
-# T-DSL t-online PAP "[ANSCHLUSSKENNUNG][T_ONLINE_NUMMER]#[MITBENUTZER]@t-online.de"
-# hansenet CHAP "net0815@hansenet.de"
-#
-#user ""
-
-# Use the pppoe program to send the ppp packets over the Ethernet link
-# This line should work fine if this computer is the only one accessing
-# the Internet through this DSL connection. This is the right line to use
-# for most people.
-pty "/usr/sbin/pppoe -I eth0 -T 80 -m 1452"
-
-# If the computer connected to the Internet using pppoe is not being used
-# by other computers as a gateway to the Internet, you can try the following
-# line instead, for a small gain in speed:
-#pty "/usr/sbin/pppoe -I eth0 -T 80"
-
-# An even more conservative version of the previous line, if things
-# don't work using -m 1452...
-#pty "/usr/sbin/pppoe -I eth0 -T 80 -m 1412"
-
-
-# The following two options should work fine for most DSL users.
-
-# Assumes that your IP address is allocated dynamically
-# by your DSL provider...
-noipdefault
-# Comment out if you already have the correct default route installed
-defaultroute
-replacedefaultroute
-usepeerdns
-
-##
-# Section 2
-#
-# Uncomment if your DSL provider charges by minute connected
-# and you want to use demand-dialing.
-#
-# Disconnect after 300 seconds (5 minutes) of idle time.
-
-#demand
-#idle 300
-
-##
-# Section 3
-#
-# You shouldn't need to change these options...
-
-hide-password
-lcp-echo-interval 20
-lcp-echo-failure 3
-# Override any connect script that may have been set in /etc/ppp/options.
-connect /bin/true
-noauth
-persist
-mtu 1492
diff --git a/packages/ppp-dsl/files/ppp_on_boot.dsl b/packages/ppp-dsl/files/ppp_on_boot.dsl
deleted file mode 100755
index f1d5183b38..0000000000
--- a/packages/ppp-dsl/files/ppp_on_boot.dsl
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-#
-
-# The location of the ppp daemon itself (shouldn't need to be changed)
-PPPD=/usr/sbin/pppd
-
-# The Ethernet interface the DSL modem is connected to. If you change this,
-# you also need to edit the file /etc/ppp/peers/dsl-provider.
-INTERFACE=eth0
-
-# Bring the interface up
-/sbin/ifconfig $INTERFACE up
-
-$PPPD call dsl-provider
diff --git a/packages/ppp-dsl/ppp-dsl_0.1.bb b/packages/ppp-dsl/ppp-dsl_0.1.bb
deleted file mode 100644
index 8d63e8fc47..0000000000
--- a/packages/ppp-dsl/ppp-dsl_0.1.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SECTION = "console/network"
-DESCRIPTION = "Enables PPP dial-in through a DSL connection"
-LICENSE = "PD"
-DEPENDS = "ppp rp-pppoe"
-RDEPENDS = "ppp rp-pppoe"
-RRECOMMENDS = "kernel-module-ppp-async kernel-module-ppp-generic kernel-module-slhc"
-PR = "r5"
-
-SRC_URI = "file://dsl-provider \
- file://ppp_on_boot.dsl"
-
-do_install() {
- install -d ${D}${sysconfdir}/ppp/peers
- install -m 0644 ${WORKDIR}/dsl-provider ${D}${sysconfdir}/ppp/peers/
- install -m 0755 ${WORKDIR}/ppp_on_boot.dsl ${D}${sysconfdir}/ppp/
-}
-
-pkg_postinst() {
-if test "x$D" != "x"; then
- exit 1
-else
- if ! test -e ${sysconfdir}/ppp/ppp_on_boot; then
- ln -s ppp_on_boot.dsl ${sysconfdir}/ppp/ppp_on_boot
- fi
-fi
-}
-
-PACKAGE_ARCH = "all"
-
-CONFFILES_${PN} = "${sysconfdir}/ppp/peers/dsl-provider"