summaryrefslogtreecommitdiff
path: root/packages/petitepainture
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-21 13:40:17 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-21 13:40:17 +0000
commite0a191e234aebe57a84143f2b0bf170236a77f37 (patch)
treec0115b8ec012f2c68dead00484cb238ac9cebc47 /packages/petitepainture
parentb8f88822e375f2228652ea332257574b7c7784f5 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/21 14:13:30+01:00 local!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into marcinj.local:/home/hrw/zaurus/bb/openembedded 2005/01/21 14:13:06+01:00 local!hrw justreader: fix Settings file location (really fix #204) 2005/01/21 14:11:29+01:00 (none)!koen patch to libpcap to fix dsniff build, courtesy Bob Davies 2005/01/21 14:10:18+01:00 local!hrw transition from libstdc++ to libsupc++ Basically it allow us to drop libstdc++ dependency from some programs. Binaries are getting little bigger but don't depend on ~3.5MiB library. If your package fails during linking you have to add one line to it's .bb file: export OE_QMAKE_LINK="${CXX}" 2005/01/21 14:02:44+01:00 local!hrw we already have freedroid in meta-opie - it's in task-qpe-games as it is not from OPIE 2005/01/21 14:01:28+01:00 local!hrw disabled PARALLEL_MAKE for uae and zroadmap 2005/01/21 11:38:29+01:00 local!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into marcinj.local:/home/hrw/zaurus/bb/openembedded 2005/01/18 18:53:19+01:00 hrw.one.pl!hrw disable PARALLEL_MAKE for opie-tinykate BKrev: 41f106415qu3LUbzxrhFJByjZfa8pQ
Diffstat (limited to 'packages/petitepainture')
-rw-r--r--packages/petitepainture/petitepainture_1.4a.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/petitepainture/petitepainture_1.4a.bb b/packages/petitepainture/petitepainture_1.4a.bb
index e69de29bb2..81cb8c8686 100644
--- a/packages/petitepainture/petitepainture_1.4a.bb
+++ b/packages/petitepainture/petitepainture_1.4a.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Pressure-Sensitive Paint Program for Opie/Qtopia"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+HOMEPAGE = "http://sun.dhis.portside.net/~sakira/wiki/index.cgi?cmd=view;name=LinuxZaurus%3APetitePeinture+en"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPNAME = "petitpeintu"
+APPDESKTOP = "${WORKDIR}"
+PR = "r1"
+
+SRC_URI = "http://sun.dhis.portside.net/~sakira/archive/SPainter_${PV}_src.tar.gz \
+ file://petitpeintu.desktop \
+ file://petitpeintu.png "
+S = "${WORKDIR}/SPainter"
+
+inherit opie
+
+QMAKE_PROFILES = "spainter.pro"
+
+do_install() {
+ install -d ${D}/${palmtopdir}/pics
+ install -m 0644 *.png ${D}/${palmtopdir}/pics/
+ install -m 0644 ${WORKDIR}/petitpeintu.png ${D}/${palmtopdir}/pics/
+}