summaryrefslogtreecommitdiff
path: root/packages/nylon/nylon-scripts_cvs.bb
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2006-09-08 12:52:43 +0000
committerMartin Dietze <di@fh-wedel.de>2006-09-08 12:52:43 +0000
commit30596c3e0a0216faaaa5b1ffaa4bd0e2c816eb21 (patch)
tree41173d7708d23aba6ffb9ba20a8ffc6b40146d99 /packages/nylon/nylon-scripts_cvs.bb
parentabf168554971b3e714dd2ee2bbebf18ab91121e9 (diff)
nylon: updated images and nylon specific packages from 4G trunk
* updated list of supported packages in nylon-feed * new image nylon-image-extended aiming to put nylon-feed into one image (for debugging) * new versions of nylon-scripts, nylon-statistics, simple-firewall
Diffstat (limited to 'packages/nylon/nylon-scripts_cvs.bb')
-rw-r--r--packages/nylon/nylon-scripts_cvs.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/packages/nylon/nylon-scripts_cvs.bb b/packages/nylon/nylon-scripts_cvs.bb
index b7ce512e87..e4917d310f 100644
--- a/packages/nylon/nylon-scripts_cvs.bb
+++ b/packages/nylon/nylon-scripts_cvs.bb
@@ -5,14 +5,17 @@ SECTION = "base"
PRIORITY = "optional"
MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
LICENSE = "GPLv2"
-PV = "1:0.0+cvs${SRCDATE}"
+SRCDATE = "20060114"
+PV = "1.0.0+cvs${SRCDATE}"
PR = "r2"
+RDEPENDS = "bash"
SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
S = "${WORKDIR}/${PN}"
INHIBIT_PACKAGE_STRIP = "1"
do_install() {
+ install -d -m 755 ${D}
(cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
}
@@ -21,8 +24,8 @@ if test "x$D" != "x"; then
exit 1
else
update-rc.d -s hostap defaults 14
- update-rc.d -s firewall defaults 20
- update-rc.d -s routing defaults 20
+ update-rc.d -s firewall defaults 16
+ update-rc.d -s routing defaults 17
update-rc.d -s emergency-ip defaults 98
update-rc.d -s flash-backup start 38 S . stop 38 0 6 .
update-rc.d -s dummydate start 50 S . stop 50 0 6 .
@@ -46,8 +49,6 @@ fi
pkg_postrm() {
#!/bin/sh -e
update-rc.d hostap remove
-update-rc.d bridge remove
-update-rc.d ipaliases remove
update-rc.d firewall remove
update-rc.d routing remove
update-rc.d emergency-ip remove
@@ -55,4 +56,5 @@ update-rc.d flash-backup remove
update-rc.d dummydate remove
}
-CONFFILES_${PN} = "/etc/nylon/backup.list /etc/nylon/hostap.conf /etc/nylon/interfaces.conf /etc/nylon/route.list"
+CONFFILES_${PN} = "/etc/nylon/backup.list /etc/nylon/hostap.conf /etc/nylon/check-process.list \
+ /etc/nylon/interfaces.conf /etc/nylon/route.list /etc/nylon/wds-bridge.conf"