summaryrefslogtreecommitdiff
path: root/packages/mythtv/mythtv_0.18.1.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-25 17:48:24 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-25 17:48:24 +0000
commit7a4d5b91f95ab60a68440d55e623a80a03c63bd8 (patch)
tree5ab52f6a6b4401c8b0951d65643b1e15988e5226 /packages/mythtv/mythtv_0.18.1.bb
parent0600591677d74c93ddc2bb2ef51b633ae0c36b21 (diff)
mythtv: unified, need testing
Diffstat (limited to 'packages/mythtv/mythtv_0.18.1.bb')
-rw-r--r--packages/mythtv/mythtv_0.18.1.bb37
1 files changed, 4 insertions, 33 deletions
diff --git a/packages/mythtv/mythtv_0.18.1.bb b/packages/mythtv/mythtv_0.18.1.bb
index 2686fa86a2..1602ce0e42 100644
--- a/packages/mythtv/mythtv_0.18.1.bb
+++ b/packages/mythtv/mythtv_0.18.1.bb
@@ -1,34 +1,10 @@
-DESCRIPTION = "A full featured personal video recorder system."
-HOMEPAGE = "http://www.mythtv.org"
-LICENSE = "GPL"
-SECTION = "x11/multimedia"
-DEPENDS = "libxinerama lame libxv libxxf86vm libxvmc lirc qt-x11-free"
-RDEPENDS = "qt-x11-plugins-sqldrivers qt-x11-plugins-imageformats"
-PR = "r1"
-
-SRC_URI = "http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2 \
- file://msmpeg-underscore-pic.patch;patch=1 \
- file://settings.pro"
-
-inherit qmake qt3x11
-
-# there is a -march=586 somewhere in the source tree
-COMPATIBLE_HOST = 'i.86.*-linux'
+require mythtv.inc
-QMAKE_PROFILES = "mythtv.pro"
+PR = "r1"
-def mythtv_arch(d):
- import bb, re
- arch = bb.data.getVar('TARGET_ARCH', d, 1)
- if re.match("^i.86$", arch):
- arch = "x86"
- elif arch == "x86_64":
- arch = "x86"
- elif arch == "arm":
- arch = "armv4l"
- return arch
+SRC_URI += "file://msmpeg-underscore-pic.patch;patch=1 \
+ file://settings.pro"
-MYTHTV_ARCH := "${@mythtv_arch(d)}"
do_configure_prepend() {
# it's not autotools anyway, so we call ./configure directly
@@ -70,8 +46,3 @@ do_configure_prepend() {
sed 's!PREFIX =.*!PREFIX = ${prefix}!' < settings.pro > settings.pro.new
mv settings.pro.new settings.pro
}
-
-do_install() {
- oe_runmake INSTALL_ROOT=${D} install
-}
-