summaryrefslogtreecommitdiff
path: root/packages/mono/mono-native_1.2.5.1.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:33:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:33:28 +0000
commit6e90aae26efa66553063b74b9afa9563b70fb982 (patch)
treedc0273068963d8e57f48f75875e5236153cf1cd9 /packages/mono/mono-native_1.2.5.1.bb
parent496d5415774f03b6e09aee17763ac9432d9c2755 (diff)
parent62007cb1fac3e5a7f4a09b61c7d3c3b7cd5fc8a7 (diff)
merge of '55c714e37be4606a4166b3df883d5f404d3889bf'
and 'd714000fc8a6b75093a93f01782724b65d31eac1'
Diffstat (limited to 'packages/mono/mono-native_1.2.5.1.bb')
-rw-r--r--packages/mono/mono-native_1.2.5.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/mono/mono-native_1.2.5.1.bb b/packages/mono/mono-native_1.2.5.1.bb
new file mode 100644
index 0000000000..7ac2246b3a
--- /dev/null
+++ b/packages/mono/mono-native_1.2.5.1.bb
@@ -0,0 +1,23 @@
+require mono_1.2.5.inc
+PR = "r1"
+DEPENDS = "glib-2.0-native perl-native"
+
+SRC_URI += "file://mono-fix-libdir-path.patch;patch=1"
+
+PARALLEL_MAKE = ""
+
+inherit native
+
+#do_stage_prepend() {
+# install -m 755 ${S}/mono/monoburg/monoburg ${STAGING_BINDIR}
+#}
+
+do_fix_libtool_name() {
+ # inherit native will make that all native tools that are being
+ # built are prefixed with something like "i686-linux-",
+ # including libtool. Fix up some hardcoded libtool names:
+ for i in "${S}"/runtime/*-wrapper.in; do
+ sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+ done
+}
+addtask fix_libtool_name after do_patch before do_configure