summaryrefslogtreecommitdiff
path: root/packages/mono/files
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:34:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:34:07 +0000
commit2f8521c6d1173dd650d9ae2bba8c18e690fa3b1f (patch)
tree06bc2b997b60797bc42f696f3427f92890089d2b /packages/mono/files
parent0d0bf315513039bd8560ac91865c7174e789d675 (diff)
parent6e90aae26efa66553063b74b9afa9563b70fb982 (diff)
merge of '603b2d0c7e4ad80e5779bd3bbdb822331cc0ea2b'
and '6ab53da82d157971966f5a17d0c29d54df22cac9'
Diffstat (limited to 'packages/mono/files')
-rw-r--r--packages/mono/files/genmdesc-cpp.patch22
-rw-r--r--packages/mono/files/mono-fix-libdir-path.patch11
2 files changed, 33 insertions, 0 deletions
diff --git a/packages/mono/files/genmdesc-cpp.patch b/packages/mono/files/genmdesc-cpp.patch
new file mode 100644
index 0000000000..56eca8effd
--- /dev/null
+++ b/packages/mono/files/genmdesc-cpp.patch
@@ -0,0 +1,22 @@
+--- mono-1.2.5.1/mono/mini/genmdesc.pl.orig 2007-10-03 21:02:07.000000000 +0200
++++ mono-1.2.5.1/mono/mini/genmdesc.pl 2007-10-03 21:06:16.000000000 +0200
+@@ -36,7 +36,9 @@
+ $i++;
+ }
+ close (OPS);
+- my $cpp = "cpp -undef ";
++ my $cpp = $ENV{"CPP"};
++ $cpp = "cpp" unless defined $cpp;
++ $cpp .= " -undef ";
+ foreach (@defines) {
+ $cpp .= " -U$_";
+ $arch_found = 1 if $arch eq $_;
+@@ -44,7 +46,7 @@
+ die "$arch arch is not supported.\n" unless $arch_found;
+
+ $cpp .= " -D$arch $srcdir/mini-ops.h|";
+- #print "Running: $cpp\n";
++ print "Running: $cpp\n";
+ open (OPS, $cpp) || die "Cannot execute cpp: $!";
+ while (<OPS>) {
+ next unless /MINI_OP\s*\(\s*(\S+?)\s*,\s*"(.*?)"/;
diff --git a/packages/mono/files/mono-fix-libdir-path.patch b/packages/mono/files/mono-fix-libdir-path.patch
new file mode 100644
index 0000000000..9255117bf8
--- /dev/null
+++ b/packages/mono/files/mono-fix-libdir-path.patch
@@ -0,0 +1,11 @@
+--- mono-1.2.5/scripts/Makefile.am.orig 2007-09-27 04:23:39.000000000 +0200
++++ mono-1.2.5/scripts/Makefile.am 2007-09-27 04:24:19.000000000 +0200
+@@ -92,7 +92,7 @@
+ mono_instdir = $(shell cygpath -m $(libdir))/mono
+ else
+ plat_bindir = $(bindir)
+-mono_instdir = $(prefix)/lib/mono
++mono_instdir = $(libdir)/mono
+ endif
+
+ REWRITE_COMMON = sed \